dev-python/lockfile: Add pypy3 support
authorJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 06:02:58 +0000 (08:02 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 10:12:07 +0000 (12:12 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/lockfile/lockfile-0.10.2.ebuild

index 5e13652981d9d0ef15a6a82619cc59196296d066..12c0bc08d4f83a95a5fc318ea6b7d9e453b44fa5 100644 (file)
@@ -3,7 +3,8 @@
 # $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
 
 inherit distutils-r1
 
@@ -16,7 +17,8 @@ SLOT="0"
 KEYWORDS="~amd64 ~arm ~ppc ~x86"
 IUSE="doc test"
 
-DEPEND="dev-python/pbr[${PYTHON_USEDEP}]
+DEPEND="
+       dev-python/pbr[${PYTHON_USEDEP}]
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? ( dev-python/nose[${PYTHON_USEDEP}] )"
 RDEPEND=""