dev-haskell/edisoncore: new package, a depend of sci-mathematics/agda-2.5.2
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 15 Feb 2017 22:03:47 +0000 (22:03 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 10:21:20 +0000 (10:21 +0000)
A library of efficent, purely-functional data structures (Core Implementations)

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/edisoncore/Manifest [new file with mode: 0644]
dev-haskell/edisoncore/edisoncore-1.3.1.1.ebuild [new file with mode: 0644]
dev-haskell/edisoncore/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/edisoncore/Manifest b/dev-haskell/edisoncore/Manifest
new file mode 100644 (file)
index 0000000..a2b6a4c
--- /dev/null
@@ -0,0 +1 @@
+DIST EdisonCore-1.3.1.1.tar.gz 80699 SHA256 3e0720ee3b179304f563b99dd446c1d6911e31ddc4d0f78d6550b18e59ed501b SHA512 2e290a5c792a136931387936f457a45913edeedb9eda8006649b974d9aea294b9f1b7e5b2aa020c3ed151934cef8b2bd228e2cb56f7db37f35d59dcb23f7bcb8 WHIRLPOOL 1bc8c100909dba5da9023d14683b7cfa9218ee38c33e14bf1e5315c729716edd88bbe7d83cc745d3944647863c81e89fbc703801a57dd51d32fbadfc80204fe1
diff --git a/dev-haskell/edisoncore/edisoncore-1.3.1.1.ebuild b/dev-haskell/edisoncore/edisoncore-1.3.1.1.ebuild
new file mode 100644 (file)
index 0000000..a69e0f0
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="EdisonCore"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library of efficent, purely-functional data structures (Core Implementations)"
+HOMEPAGE="http://rwd.rdockins.name/edison/home/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/edisonapi-1.3:=[profile?] <dev-haskell/edisonapi-1.4:=[profile?]
+       dev-haskell/mtl:=[profile?]
+       >=dev-haskell/quickcheck-2.8.2:2=[profile?] <dev-haskell/quickcheck-3:2=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.10
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/edisoncore/metadata.xml b/dev-haskell/edisoncore/metadata.xml
new file mode 100644 (file)
index 0000000..c483b30
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               This package provides the core Edison data structure implementations,
+               including multiple sequence, set, bag, and finite map concrete
+               implementations with various performance characteristics. The
+               implementations in this package have no dependencies other than those
+               commonly bundled with Haskell compilers.
+       </longdescription>
+</pkgmetadata>