media-video/ccextractor: Install docs
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 26 Aug 2018 07:29:04 +0000 (09:29 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 26 Aug 2018 08:51:26 +0000 (10:51 +0200)
Bug: https://bugs.gentoo.org/651524
Package-Manager: Portage-2.3.48, Repoman-2.3.10

media-video/ccextractor/ccextractor-0.85-r2.ebuild [new file with mode: 0644]

diff --git a/media-video/ccextractor/ccextractor-0.85-r2.ebuild b/media-video/ccextractor/ccextractor-0.85-r2.ebuild
new file mode 100644 (file)
index 0000000..1ae06ed
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="Extract closed captioning subtitles from video to SRT"
+HOMEPAGE="https://www.ccextractor.org/"
+SRC_URI="mirror://sourceforge/ccextractor/${PN}-src-nowin.${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       media-libs/libpng:0=
+       sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}
+       app-arch/unzip
+       virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}/src"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_install() {
+       cmake-utils_src_install
+       dodoc ../docs/*.TXT
+}