x11-misc/alacarte: bump to 3.36.0, use py3 and python-single-r1
authorMart Raudsepp <leio@gentoo.org>
Tue, 19 May 2020 07:23:49 +0000 (10:23 +0300)
committerMart Raudsepp <leio@gentoo.org>
Tue, 19 May 2020 07:24:04 +0000 (10:24 +0300)
Closes: https://bugs.gentoo.org/719990
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
x11-misc/alacarte/Manifest
x11-misc/alacarte/alacarte-3.36.0.ebuild [new file with mode: 0644]

index 4c7789be89ed571d441c0291c6d8f1e698a39489..e0dbcbeb9530ee318f67107c9a2a22fa8381e436 100644 (file)
@@ -1 +1,2 @@
 DIST alacarte-3.11.91.tar.xz 199128 BLAKE2B 711baf87d48b79cf52ad41bc9292c848a0f69477388580b9dddc068c8184178ae1e3c455a5b9ac6d99ef442d4b36544a45852aa134744379fc14b6c69c6a77df SHA512 b4b5ead4ba0b9742ea0530ecb5362afa970125d29750aaf147be6fd477f238b9c360307ce1df2a56330a69cd9c849a0dde4be44b36bf55377f42e30429411935
+DIST alacarte-3.36.0.tar.xz 201088 BLAKE2B 26c924a8a88c014358db38496cb8a20eca82e9b3d514a9feefa64db3674527cef454346c538a1cdb04ebbb384a64dee395738d8d2a19f4d2445e887f5714f8d6 SHA512 7406fef4c59f94f26d52ad6b52ddd8a5183e9ceb50834aecd5e83f60d996ab4efd09ecbc9d3568d65fe1dd9290e446b5c5c5f6ad89c7e81b0ef304d2a10476b9
diff --git a/x11-misc/alacarte/alacarte-3.36.0.ebuild b/x11-misc/alacarte/alacarte-3.36.0.ebuild
new file mode 100644 (file)
index 0000000..03f6ba7
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://git.gnome.org/browse/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+       ${PYTHON_DEPS}
+       $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+       >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+       x11-libs/gdk-pixbuf:2[introspection]
+       x11-libs/gtk+:3[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+       >=dev-util/intltool-0.40.0
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+
+src_install() {
+       gnome2_src_install
+       python_optimize
+}