Cleanup.
authorLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 20:38:43 +0000 (20:38 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 20:38:43 +0000 (20:38 +0000)
Package-Manager: portage-2.1.2_rc4-r8

net-www/mod_ssl/ChangeLog
net-www/mod_ssl/mod_ssl-2.8.25-r10.ebuild
net-www/mod_ssl/mod_ssl-2.8.28.ebuild

index 2da4b74bf0a725f7862d26e4714ad520dd5775b2..5b3953dd9ee8ee256303260a36e2a5c6cacd832c 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-www/mod_ssl
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.110 2006/07/29 20:04:34 kloeri Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.111 2007/01/14 20:38:43 chtekk Exp $
+
+  14 Jan 2007; Luca Longinotti <chtekk@gentoo.org> -files/mod_ssl.conf,
+  -files/ssl.default-vhost.conf, mod_ssl-2.8.25-r10.ebuild,
+  mod_ssl-2.8.28.ebuild:
+  Cleanup.
 
 *mod_ssl-2.8.28 (29 Jul 2006)
 
index 040808f1bd89df9066475f998b0aeaad5386e739..0e50a99bda57e779c5db9ea36491690189779b99 100644 (file)
@@ -1,24 +1,24 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.25-r10.ebuild,v 1.9 2006/06/04 18:49:05 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.25-r10.ebuild,v 1.10 2007/01/14 20:38:43 chtekk Exp $
 
-inherit apache-module
+inherit apache-module multilib
 
-MY_P=${P}-1.3.34
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+
+MY_P="${P}-1.3.34"
 
-DESCRIPTION="An SSL module for the Apache 1.3 Web server"
+DESCRIPTION="An SSL module for the Apache 1.3 webserver."
 HOMEPAGE="http://www.modssl.org/"
 SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
-
 LICENSE="as-is"
 SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
 IUSE=""
 
 DEPEND=">=dev-libs/openssl-0.9.6k"
 RDEPEND="${DEPEND}"
 
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
 
 APACHE1_MOD_FILE="${S}/pkg.sslmod/libssl.so"
 APACHE1_MOD_CONF="10_${PN}"
@@ -31,45 +31,49 @@ DOCFILES="ANNOUNCE CHANGES CREDITS LICENSE NEWS README*"
 need_apache1
 
 src_unpack() {
-       unpack ${A} || die
-       cd ${S} || die
+       unpack ${A}
+       cd "${S}"
 
-       # proper path to openssl
+       # Proper path to OpenSSL
        sed -i -e 's:^\(openssl=\).*:\1"/usr/bin/openssl":' pkg.contrib/cca.sh
 }
 
 src_compile() {
+       local myconf=""
+
        if has_version '=sys-libs/gdbm-1.8.3*' ; then
-            myconf="--enable-rule=SSL_SDBM"
+               myconf="${myconf} --enable-rule=SSL_SDBM"
        fi
 
        SSL_BASE=SYSTEM \
        ./configure \
-               --with-apxs=${APXS1} ${myconf} || die "bad ./configure"
-       make || die "compile problem"
+               --with-apxs=${APXS1} \
+               ${myconf} \
+               || die "./configure failed"
+       emake || die "emake failed"
 }
 
 src_install() {
        apache1_src_install
 
-       insinto ${APACHE1_VHOSTDIR}
-       doins ${FILESDIR}/${VHOSTFILE}.conf
+       insinto "${APACHE1_VHOSTDIR}"
+       doins "${FILESDIR}/${VHOSTFILE}.conf"
 
-       exeinto /usr/lib/ssl/mod_ssl
-       doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+       exeinto /usr/$(get_libdir)/ssl/mod_ssl
+       doexe pkg.contrib/*.sh "${FILESDIR}/gentestcrt.sh"
 
        dodir /usr/share/doc/${PF}/html
-       cp -pPR pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+       cp -pPR pkg.ssldoc/* "${D}/usr/share/doc/${PF}/html"
 }
 
 pkg_postinst() {
-       install -d -o root -g root -m0755 ${ROOT}${APACHE1_CONFDIR}/ssl
+       install -d -m0755 -o root -g root "${ROOT}${APACHE1_CONFDIR}/ssl"
 
        apache1_pkg_postinst
 
-       cd ${ROOT}${APACHE1_CONFDIR}/ssl
-       einfo "Generating self-signed test certificate in ${APACHE1_CONFDIR}/ssl..."
+       cd "${ROOT}${APACHE1_CONFDIR}/ssl"
+       einfo "Generating self-signed test certificate in ${APACHE1_CONFDIR}/ssl ..."
        einfo "(Ignore any message from the yes command below)"
-       yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+       yes "" | "${ROOT}"/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
        einfo
 }
index dd292d7bec00524c1395d2395993a7ceb7d65029..8dcb5c80b5d3bc68d5656a06d14b0836a9a9c41b 100644 (file)
@@ -1,24 +1,24 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.28.ebuild,v 1.1 2006/07/29 20:04:34 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.28.ebuild,v 1.2 2007/01/14 20:38:43 chtekk Exp $
 
-inherit apache-module
+inherit apache-module multilib
 
-MY_P=${P}-1.3.37
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+MY_P="${P}-1.3.37"
 
-DESCRIPTION="An SSL module for the Apache 1.3 Web server"
+DESCRIPTION="An SSL module for the Apache 1.3 webserver."
 HOMEPAGE="http://www.modssl.org/"
 SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
-
 LICENSE="as-is"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
 IUSE=""
 
 DEPEND=">=dev-libs/openssl-0.9.6k"
 RDEPEND="${DEPEND}"
 
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
 
 APACHE1_MOD_FILE="${S}/pkg.sslmod/libssl.so"
 APACHE1_MOD_CONF="10_${PN}"
@@ -31,45 +31,49 @@ DOCFILES="ANNOUNCE CHANGES CREDITS LICENSE NEWS README*"
 need_apache1
 
 src_unpack() {
-       unpack ${A} || die
-       cd ${S} || die
+       unpack ${A}
+       cd "${S}"
 
-       # proper path to openssl
+       # Proper path to OpenSSL
        sed -i -e 's:^\(openssl=\).*:\1"/usr/bin/openssl":' pkg.contrib/cca.sh
 }
 
 src_compile() {
+       local myconf=""
+
        if has_version '=sys-libs/gdbm-1.8.3*' ; then
-            myconf="--enable-rule=SSL_SDBM"
+               myconf="${myconf} --enable-rule=SSL_SDBM"
        fi
 
        SSL_BASE=SYSTEM \
        ./configure \
-               --with-apxs=${APXS1} ${myconf} || die "bad ./configure"
-       make || die "compile problem"
+               --with-apxs=${APXS1} \
+               ${myconf} \
+               || die "./configure failed"
+       emake || die "emake failed"
 }
 
 src_install() {
        apache1_src_install
 
-       insinto ${APACHE1_VHOSTDIR}
-       doins ${FILESDIR}/${VHOSTFILE}.conf
+       insinto "${APACHE1_VHOSTDIR}"
+       doins "${FILESDIR}/${VHOSTFILE}.conf"
 
-       exeinto /usr/lib/ssl/mod_ssl
-       doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+       exeinto /usr/$(get_libdir)/ssl/mod_ssl
+       doexe pkg.contrib/*.sh "${FILESDIR}/gentestcrt.sh"
 
        dodir /usr/share/doc/${PF}/html
-       cp -pPR pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+       cp -pPR pkg.ssldoc/* "${D}/usr/share/doc/${PF}/html"
 }
 
 pkg_postinst() {
-       install -d -o root -g root -m0755 ${ROOT}${APACHE1_CONFDIR}/ssl
+       install -d -m0755 -o root -g root "${ROOT}${APACHE1_CONFDIR}/ssl"
 
        apache1_pkg_postinst
 
-       cd ${ROOT}${APACHE1_CONFDIR}/ssl
-       einfo "Generating self-signed test certificate in ${APACHE1_CONFDIR}/ssl..."
+       cd "${ROOT}${APACHE1_CONFDIR}/ssl"
+       einfo "Generating self-signed test certificate in ${APACHE1_CONFDIR}/ssl ..."
        einfo "(Ignore any message from the yes command below)"
-       yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+       yes "" | "${ROOT}"/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
        einfo
 }