Necessary chmod for unprivileged operation was missing, added. Primary maintainership...
authorTony Vroon <chainsaw@gentoo.org>
Sat, 2 Dec 2006 15:29:31 +0000 (15:29 +0000)
committerTony Vroon <chainsaw@gentoo.org>
Sat, 2 Dec 2006 15:29:31 +0000 (15:29 +0000)
Package-Manager: portage-2.1.2_rc2-r3

app-mobilephone/smstools/ChangeLog
app-mobilephone/smstools/files/2.2.12-sendsms-chmod.patch [new file with mode: 0644]
app-mobilephone/smstools/files/digest-smstools-2.2.12-r1 [new file with mode: 0644]
app-mobilephone/smstools/metadata.xml
app-mobilephone/smstools/smstools-2.2.12-r1.ebuild [new file with mode: 0644]

index 14900fdbadc130fdd12c9550880c9d41b0c8c357..393569bf5ff1db9e397b361143b6c1b735790e24 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for app-mobilephone/smstools
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smstools/ChangeLog,v 1.7 2006/12/02 14:46:29 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smstools/ChangeLog,v 1.8 2006/12/02 15:29:31 chainsaw Exp $
+
+*smstools-2.2.12-r1 (02 Dec 2006)
+
+  02 Dec 2006; Tony Vroon <chainsaw@gentoo.org>
+  +files/2.2.12-sendsms-chmod.patch, metadata.xml, -smstools-2.2.12.ebuild,
+  +smstools-2.2.12-r1.ebuild:
+  Necessary chmod for unprivileged operation was missing, added. Primary
+  maintainership not respected in mobile-phone herd, unherding package.
 
 *smstools-2.2.12 (02 Dec 2006)
 
diff --git a/app-mobilephone/smstools/files/2.2.12-sendsms-chmod.patch b/app-mobilephone/smstools/files/2.2.12-sendsms-chmod.patch
new file mode 100644 (file)
index 0000000..716e316
--- /dev/null
@@ -0,0 +1,9 @@
+diff -uNr smstools.ORIG/scripts/sendsms smstools/scripts/sendsms
+--- smstools.ORIG/scripts/sendsms      2006-12-02 15:26:09.000000000 +0000
++++ smstools/scripts/sendsms   2006-12-02 15:26:52.000000000 +0000
+@@ -26,3 +26,5 @@
+ echo "" >> $FILE
+ echo -n "$TEXT" >> $FILE
++chmod 660 $FILE
++
diff --git a/app-mobilephone/smstools/files/digest-smstools-2.2.12-r1 b/app-mobilephone/smstools/files/digest-smstools-2.2.12-r1
new file mode 100644 (file)
index 0000000..3299215
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 862a7a14c94e6ddd3afb614b437bd1b8 smstools-2.2.12.tar.gz 465993
+RMD160 552e59fb0026cee1c54f70caca4d4521bad5a220 smstools-2.2.12.tar.gz 465993
+SHA256 eb85c672d4fd1afd822c792a529148a8928ccd845d935098ad5c74791abf6785 smstools-2.2.12.tar.gz 465993
index 2060950c5585b863dfb7dddd9e1e6be7d2f2f982..c20e1351f56ebe7f7fb160c0d83ef20b2e93dc89 100644 (file)
@@ -1,7 +1,7 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-  <herd>mobile-phone</herd>
+  <herd>no-herd</herd>
   <maintainer>
           <email>chainsaw@gentoo.org</email>
           <name>Tony Vroon</name>
diff --git a/app-mobilephone/smstools/smstools-2.2.12-r1.ebuild b/app-mobilephone/smstools/smstools-2.2.12-r1.ebuild
new file mode 100644 (file)
index 0000000..a4d209e
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smstools/smstools-2.2.12-r1.ebuild,v 1.1 2006/12/02 15:29:31 chainsaw Exp $
+
+inherit eutils
+
+DESCRIPTION="Send and receive short messages through GSM modems"
+HOMEPAGE="http://smstools.meinemullemaus.de/"
+SRC_URI="http://www.meinemullemaus.de/software/${PN}/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="stats"
+
+RDEPEND="sys-process/procps
+        stats? ( >=dev-libs/mm-1.4.0 )"
+
+S="${WORKDIR}"/${PN}
+
+pkg_setup() {
+       enewgroup sms
+       enewuser smsd -1 -1 /var/spool/sms sms
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}"/2.2.1-skip-dirlock.patch
+       epatch "${FILESDIR}"/"${PV}"-buffer-overflow.patch
+       epatch "${FILESDIR}"/"${PV}"-sendsms-chmod.patch
+       if use stats; then
+               sed -i -e "s:CFLAGS += -D NOSTATS:#CFLAGS += -D NOSTATS:" src/Makefile
+       fi
+}
+
+src_compile() {
+       cd src
+       emake || die "emake failed"
+}
+
+src_install() {
+       dobin src/smsd
+       cd "${S}"/scripts
+       dobin sendsms sms2html sms2unicode unicode2sms
+       dobin hex2bin hex2dec email2sms
+       dodoc mysmsd smsevent smsresend sms2xml sql_demo
+
+       keepdir /var/spool/sms/incoming
+       keepdir /var/spool/sms/outgoing
+       keepdir /var/spool/sms/checked
+       chown -R smsd:sms "${D}"/var/spool/sms
+
+       newinitd "${FILESDIR}"/smsd.initd smsd
+       insopts -o smsd -g sms -m0644
+       insinto /etc
+       newins "${S}"/examples/smsd.conf.easy smsd.conf
+
+       dohtml "${S}"/doc/*
+}
+
+pkg_preinst() {
+       pkg_setup
+}
+
+pkg_postinst() {
+       chown -f smsd:sms /var/log/smsd.log
+}