dev-ruby/prawn-table: Add ruby23, drop ~ppc
authorManuel Rüger <mrueg@gentoo.org>
Sun, 22 Jan 2017 02:02:33 +0000 (03:02 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Sun, 22 Jan 2017 02:02:33 +0000 (03:02 +0100)
Package-Manager: portage-2.3.3

dev-ruby/prawn-table/prawn-table-0.2.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/prawn-table/prawn-table-0.2.2-r1.ebuild b/dev-ruby/prawn-table/prawn-table-0.2.2-r1.ebuild
new file mode 100644 (file)
index 0000000..d6cdede
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for tables in Prawn"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+LICENSE="|| ( GPL-2+ Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha
+       >=dev-ruby/pdf-inspector-1.1.0
+       >=dev-ruby/pdf-reader-1.2
+       >=dev-ruby/prawn-1.3.0
+       )"
+
+all_ruby_prepare() {
+       sed -i -e "/[Bb]undler/s/^/#/" spec/spec_helper.rb || die
+       # Remove failing test
+       # See https://github.com/prawnpdf/prawn-table/issues/10
+       sed -i -e "/Prints table on one page when using subtable with colspan > 1/,+24 s/^/#/" spec/table_spec.rb || die
+}