sys-cluster/maui: drop old
authorAaron Bauman <bman@gentoo.org>
Fri, 13 Dec 2019 15:59:59 +0000 (10:59 -0500)
committerAaron Bauman <bman@gentoo.org>
Fri, 13 Dec 2019 16:07:42 +0000 (11:07 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
sys-cluster/maui/maui-3.3.1-r2.ebuild [deleted file]

diff --git a/sys-cluster/maui/maui-3.3.1-r2.ebuild b/sys-cluster/maui/maui-3.3.1-r2.ebuild
deleted file mode 100644 (file)
index af2623a..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils multilib
-
-DESCRIPTION="Maui Cluster Scheduler"
-HOMEPAGE="http://www.adaptivecomputing.com/products/open-source/maui/"
-SRC_URI="http://www.adaptivecomputing.com/download/${PN}/${P}.tar.gz"
-
-LICENSE="maui"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="pbs slurm"
-
-REQUIRED_USE="^^ ( pbs slurm )"
-
-DEPEND="
-       pbs? ( sys-cluster/torque )
-       slurm? ( sys-cluster/slurm )"
-RDEPEND="${DEPEND}"
-
-RESTRICT="fetch mirror"
-
-pkg_setup() {
-       if use slurm; then
-               if [ -z ${MAUI_KEY} ]; then
-                       eerror "You should set MAUI_KEY to any integer value in make.conf"
-                       return 1
-               fi
-       fi
-}
-
-src_prepare() {
-       sed -e "s:\$(INST_DIR)/lib:\$(INST_DIR)/$(get_libdir):" \
-               -i src/{moab,server,mcom}/Makefile || die
-}
-
-src_configure() {
-       local myconf
-       use pbs && myconf="--with-pbs=${EPREFIX}/usr"
-       use slurm && myconf+=" --with-wiki --with-key=${MAUI_KEY}"
-       econf \
-               --with-spooldir="${EPREFIX}"/var/spool/${PN} \
-               ${myconf}
-}
-
-src_install() {
-       emake BUILDROOT="${D}" INST_DIR="${ED}/usr" install
-       dodoc docs/README CHANGELOG
-       dohtml docs/mauidocs.html
-       newinitd "${FILESDIR}/${PN}.initd" ${PN}
-}
-
-pkg_nofetch() {
-       einfo "Please visit ${HOMEPAGE}, obtain the file"
-       einfo "${P}.tar.gz and put it in your DISTDIR directory."
-}