dev-python/parver: Bump to 0.3
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 06:01:57 +0000 (08:01 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 07:18:22 +0000 (09:18 +0200)
Closes: https://bugs.gentoo.org/719446
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/parver/Manifest
dev-python/parver/parver-0.3.ebuild [new file with mode: 0644]

index 40f1fcaaf6cda7090e47e431d1597a3a12555b0e..fa349a9db6165dfb6384006b67d6342b29b12a90 100644 (file)
@@ -1 +1,2 @@
 DIST parver-0.2.1.tar.gz 25717 BLAKE2B dd55f44b8bb43ca948fa459537385066b811fca4ff68426365b840d704c30c4a258632f1d2ac2a3967acafcbde44151f1d394ffd96a18d03c6a004ce6b29f1b1 SHA512 674e97d5bef6bb02a659ecf5e1a78fa5d597436b656d0251db20fe330a151ae8de52a3f3f0d3732ccb624ad9093116c07837ba0cbe4ae7ae664b4d47ec3333c3
+DIST parver-0.3.tar.gz 28324 BLAKE2B b7ffed6f6e03d9409ba512fb43336fa81ce4152fa066703c1de122f709410c946a1ce6fcedf8ddbdb0c9af66d8651c597f2abf3867115d89280381c6fb1f24e8 SHA512 0b31ee3c3fc24b056a97ccb9df10dec69ca66f4690b7f01ae84fbe583b77cf713b98d207eaf7a34c2192eecdf4077121154fe9b59aa83fe4836080cae729a90d
diff --git a/dev-python/parver/parver-0.3.ebuild b/dev-python/parver/parver-0.3.ebuild
new file mode 100644 (file)
index 0000000..0b21ac2
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Parse and manipulate version numbers"
+HOMEPAGE="https://github.com/RazerM/parver https://pypi.org/project/parver/"
+SRC_URI="https://github.com/RazerM/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       >=dev-python/arpeggio-1.7[${PYTHON_USEDEP}]
+       dev-python/attrs[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       "
+
+DEPEND="
+       test? (
+               ${RDEPEND}
+               dev-python/hypothesis[${PYTHON_USEDEP}]
+               dev-python/pretend[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+       # unlock dependencies
+       sed -i -e 's:~=:>=:g' setup.py || die
+
+       distutils-r1_src_prepare
+}