sys-devel/clang-runtime: Bump to 9.0.0
authorMichał Górny <mgorny@gentoo.org>
Fri, 20 Sep 2019 09:33:40 +0000 (11:33 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 20 Sep 2019 22:12:04 +0000 (00:12 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/clang-runtime/clang-runtime-9.0.0.ebuild [new file with mode: 0644]

diff --git a/sys-devel/clang-runtime/clang-runtime-9.0.0.ebuild b/sys-devel/clang-runtime/clang-runtime-9.0.0.ebuild
new file mode 100644 (file)
index 0000000..6204c84
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+       compiler-rt? (
+               ~sys-libs/compiler-rt-${PV}:${SLOT}
+               sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+       )
+       crt? (
+               || (
+                       sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+                       sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+               )
+       )
+       libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+       openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"