Add docker-machine.
authorZac Medico <zmedico@gentoo.org>
Sat, 15 Aug 2015 23:02:19 +0000 (16:02 -0700)
committerZac Medico <zmedico@gentoo.org>
Sat, 15 Aug 2015 23:03:17 +0000 (16:03 -0700)
Package-Manager: portage-2.2.20.1

app-emulation/docker-machine/Manifest [new file with mode: 0644]
app-emulation/docker-machine/docker-machine-0.4.1.ebuild [new file with mode: 0644]
app-emulation/docker-machine/metadata.xml [new file with mode: 0644]

diff --git a/app-emulation/docker-machine/Manifest b/app-emulation/docker-machine/Manifest
new file mode 100644 (file)
index 0000000..7e184a7
--- /dev/null
@@ -0,0 +1 @@
+DIST docker-machine-0.4.1.tar.gz 1620966 SHA256 f089657b2de7a3ce15374e69be3f654b0866f75eb077ca363f8a5933ccf51cda SHA512 29b21c075c7964cce00cda484bb31768988c95d6e1a9c4aa625619bead49aebe5b756fdaee7be07baa469c2a675538e69c1e2d3a33cfd32c0c8b79dd4dc8b6b7 WHIRLPOOL 8f200b43f4d40b170646cd3b96b8dac7ae56014641d30ed82ab53eb38be537a408a45fcef7d1f97eba632c86f471516ca3c7f19c121072a72b19847b9d04fe82
diff --git a/app-emulation/docker-machine/docker-machine-0.4.1.ebuild b/app-emulation/docker-machine/docker-machine-0.4.1.ebuild
new file mode 100644 (file)
index 0000000..bf45246
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_PN=github.com/docker/machine/...
+
+if [[ ${PV} = *9999* ]]; then
+       inherit golang-vcs
+else
+       KEYWORDS="~amd64"
+       EGIT_COMMIT="v${PV}"
+       SRC_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Machine management for a container-centric world"
+HOMEPAGE="https://docs.docker.com/machine/ "
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+RESTRICT="test"
+DEPEND=""
+RDEPEND=""
+S=${WORKDIR}/${P}/src/${EGO_PN%/*}
+
+src_compile() {
+       GOPATH="${WORKDIR}/${P}:${S}/Godeps/_workspace:$(get_golibdir_gopath)" \
+               go build -v -work -x ${EGO_BUILD_FLAGS} -o ${PN} || die
+}
+
+src_install() {
+       dobin ${PN} || die
+}
diff --git a/app-emulation/docker-machine/metadata.xml b/app-emulation/docker-machine/metadata.xml
new file mode 100644 (file)
index 0000000..77868d9
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer>
+    <email>zmedico@gentoo.org</email>
+  </maintainer>
+  <upstream>
+    <remote-id type="github">docker/machine</remote-id>
+  </upstream>
+</pkgmetadata>