media-libs/mesa: Install VAAPI drivers to correct location.
authorMatt Turner <mattst88@gentoo.org>
Sat, 29 Aug 2015 22:37:51 +0000 (15:37 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 29 Aug 2015 23:21:11 +0000 (16:21 -0700)
Bug: https://bugs.gentoo.org/549564

media-libs/mesa/mesa-10.6.5.ebuild
media-libs/mesa/mesa-11.0.0_rc1.ebuild
media-libs/mesa/mesa-9999.ebuild

index b5ac47a6a4e3159199c6cc81d029dcce962b3b64..4386f87e25779e3a1c8655a42b9e848c5c0fee9d 100644 (file)
@@ -234,6 +234,8 @@ multilib_src_configure() {
                        $(use_enable xa)
                        $(use_enable xvmc)
                "
+               use vaapi && myconf+="--with-va-libdir=/usr/$(get_libdir)/va/drivers"
+
                gallium_enable swrast
                gallium_enable video_cards_vmware svga
                gallium_enable video_cards_nouveau nouveau
index c4010308be83c8943c84e76e5b2a6940c6ea894f..73f53c5336113d3c3348a89c4b4180c4a01400b6 100644 (file)
@@ -234,6 +234,8 @@ multilib_src_configure() {
                        $(use_enable xa)
                        $(use_enable xvmc)
                "
+               use vaapi && myconf+="--with-va-libdir=/usr/$(get_libdir)/va/drivers"
+
                gallium_enable swrast
                gallium_enable video_cards_vmware svga
                gallium_enable video_cards_nouveau nouveau
index 1e80c54a2a8115698ac6f4198bf180df59df1ae6..ceb2c93bae53b6ae0f9b9d581ca446dd1a2fa0cd 100644 (file)
@@ -235,6 +235,8 @@ multilib_src_configure() {
                        $(use_enable xa)
                        $(use_enable xvmc)
                "
+               use vaapi && myconf+="--with-va-libdir=/usr/$(get_libdir)/va/drivers"
+
                gallium_enable swrast
                gallium_enable video_cards_vmware svga
                gallium_enable video_cards_nouveau nouveau