sys-libs/libomp: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:56 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:56 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/libomp/libomp-10.0.0.9999.ebuild
sys-libs/libomp/libomp-9.0.1.9999.ebuild

index 107506fa8c8a2827ae7ce9d5edd02748cfbcf775..905a345680bd3a6a9703e74591f5946a56081a5d 100644 (file)
@@ -13,8 +13,8 @@ inherit cmake-multilib git-r3 linux-info multiprocessing python-any-r1
 DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
 HOMEPAGE="https://openmp.llvm.org"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/openmp.git
-       https://github.com/llvm-mirror/openmp.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/openmp
 
 LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
 SLOT="0"
@@ -71,6 +71,11 @@ pkg_setup() {
        use test && python-any-r1_pkg_setup
 }
 
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' openmp
+}
+
 multilib_src_configure() {
        local libdir="$(get_libdir)"
        local mycmakeargs=(
index 024defb5b3bea06886447e16c3c4e5487943313b..df9c8ea5a367dddb89983af2244c27dee6726243 100644 (file)
@@ -13,9 +13,9 @@ inherit cmake-multilib git-r3 linux-info multiprocessing python-any-r1
 DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
 HOMEPAGE="https://openmp.llvm.org"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/openmp.git
-       https://github.com/llvm-mirror/openmp.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/openmp
 
 LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
 SLOT="0"
@@ -72,6 +72,11 @@ pkg_setup() {
        use test && python-any-r1_pkg_setup
 }
 
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' openmp
+}
+
 multilib_src_configure() {
        local libdir="$(get_libdir)"
        local mycmakeargs=(