app-emulation/dynamips: drop old
authorSergey Popov <pinkbyte@gentoo.org>
Mon, 14 Jan 2019 09:53:53 +0000 (12:53 +0300)
committerSergey Popov <pinkbyte@gentoo.org>
Mon, 14 Jan 2019 09:54:52 +0000 (12:54 +0300)
Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.10

app-emulation/dynamips/Manifest
app-emulation/dynamips/dynamips-0.2.14-r1.ebuild [deleted file]
app-emulation/dynamips/dynamips-0.2.14-r2.ebuild [deleted file]

index 49458378e134931d7a6e8d10d962134f76ead58f..26e0ee3e5ed724b1ccef3930f57402380f0cd354 100644 (file)
@@ -1,2 +1 @@
-DIST dynamips-0.2.14-source.zip 961813 BLAKE2B 71da393bfd5624ad47eda578eafd0f5b8b535d9a93c3ebc8902901c0415168098bb27ea44e92cbb230d0cf2ebb904311665978f1b30e6d35c7792b813a5cd8d2 SHA512 8c3d85998a61cae1e3e82501a00e886c954686f9a19a44acb7dee8b13911c0155ce2cdfecbdc41ed5d279266abdf77a5c3f2753fde12217b138313ffa46dabf8
 DIST dynamips-0.2.18.tar.gz 833554 BLAKE2B 8152b436e8fc43061c5603a44ceae8feebdd4593649d2fb6a1814ca22cfce2f671f6f98df5f03ee6eeef10cf09fc444d406edd8d3b4a6037a89cf0e8301774ac SHA512 d66e32d72ecc9ebff5232377ac9aa5b966ceb08884cc7f8dc4a8cf3f56305e7cefd677624ba66278f6603a3b275c384bd0ff3905932461b1f8056106cd272a4c
diff --git a/app-emulation/dynamips/dynamips-0.2.14-r1.ebuild b/app-emulation/dynamips/dynamips-0.2.14-r1.ebuild
deleted file mode 100644 (file)
index 792a84e..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="Cisco 7200/3600 Simulator"
-HOMEPAGE="http://www.gns3.net/dynamips/"
-SRC_URI="mirror://sourceforge/project/gns-3/Dynamips/${PV}/${P}-source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="ipv6"
-
-RDEPEND="dev-libs/elfutils
-       net-libs/libpcap"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-DOCS=( ChangeLog README RELEASE-NOTES )
-
-S="${WORKDIR}"
-
-PATCHES=( "${FILESDIR}/${PV}-docs.patch" )
-
-src_prepare() {
-       # comment out DYNAMIPS_FLAGS to respect CFLAGS
-       sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
-
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               $(cmake-utils_use_enable ipv6 IPV6)
-       )
-       cmake-utils_src_configure
-}
diff --git a/app-emulation/dynamips/dynamips-0.2.14-r2.ebuild b/app-emulation/dynamips/dynamips-0.2.14-r2.ebuild
deleted file mode 100644 (file)
index 709519a..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Cisco 7200/3600 Simulator"
-HOMEPAGE="http://www.gns3.net/dynamips/"
-SRC_URI="mirror://sourceforge/project/gns-3/Dynamips/${PV}/${P}-source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="ipv6"
-
-RDEPEND="dev-libs/elfutils
-       net-libs/libpcap"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-DOCS=( ChangeLog README RELEASE-NOTES )
-
-S="${WORKDIR}"
-
-PATCHES=( "${FILESDIR}/${PV}-docs.patch" )
-
-src_prepare() {
-       # comment out DYNAMIPS_FLAGS to respect CFLAGS
-       sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
-
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DANY_COMPILER=1
-               -DENABLE_IPV6="$(usex ipv6)"
-       )
-       cmake-utils_src_configure
-}