sys-cluster/openstack-meta: TRAIN bump
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 21 Oct 2019 00:18:35 +0000 (19:18 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 21 Oct 2019 00:19:06 +0000 (19:19 -0500)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
sys-cluster/openstack-meta/openstack-meta-2019.2.0.ebuild [new file with mode: 0644]
sys-cluster/openstack-meta/openstack-meta-2019.2.9999.ebuild [new file with mode: 0644]

diff --git a/sys-cluster/openstack-meta/openstack-meta-2019.2.0.ebuild b/sys-cluster/openstack-meta/openstack-meta-2019.2.0.ebuild
new file mode 100644 (file)
index 0000000..001c620
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A openstack meta-package for installing the various openstack pieces"
+HOMEPAGE="https://openstack.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="cinder glance heat keystone neutron nova placement swift"
+
+if [[ ${PV} != *9999 ]];then
+       KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND=""
+RDEPEND="
+       keystone? ( ~sys-auth/keystone-16.0.0 )
+       swift? ( ~sys-cluster/swift-2.23.0 )
+       neutron? ( ~sys-cluster/neutron-15.0.0 )
+       glance? ( ~app-admin/glance-19.0.0 )
+       cinder? ( ~sys-cluster/cinder-15.0.0 )
+       nova? ( ~sys-cluster/nova-20.0.0 )
+       heat? ( ~sys-cluster/heat-13.0.0 )
+       placement? ( ~sys-cluster/placement-2.0.0 )
+"
diff --git a/sys-cluster/openstack-meta/openstack-meta-2019.2.9999.ebuild b/sys-cluster/openstack-meta/openstack-meta-2019.2.9999.ebuild
new file mode 100644 (file)
index 0000000..b17a0a5
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A openstack meta-package for installing the various openstack pieces"
+HOMEPAGE="https://openstack.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="cinder glance heat keystone neutron nova placement swift"
+
+if [[ ${PV} != *9999 ]];then
+       KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND=""
+RDEPEND="
+       keystone? ( ~sys-auth/keystone-${PV} )
+       swift? ( ~sys-cluster/swift-${PV} )
+       neutron? ( ~sys-cluster/neutron-${PV} )
+       glance? ( ~app-admin/glance-${PV} )
+       cinder? ( ~sys-cluster/cinder-${PV} )
+       nova? ( ~sys-cluster/nova-${PV} )
+       heat? ( ~sys-cluster/heat-${PV} )
+       placement? ( ~sys-cluster/placement-${PV} )
+"