app-backup/tarsnap: version bump to 1.0.37
authorTim Harder <radhermit@gentoo.org>
Mon, 12 Dec 2016 04:47:31 +0000 (23:47 -0500)
committerTim Harder <radhermit@gentoo.org>
Mon, 12 Dec 2016 04:47:31 +0000 (23:47 -0500)
app-backup/tarsnap/Manifest
app-backup/tarsnap/tarsnap-1.0.37.ebuild [new file with mode: 0644]

index bfc3b6724ee3e516ad7caf87676531114c0613f8..abb868bd2ea24601139aac54182e02871a82693a 100644 (file)
@@ -1 +1,2 @@
 DIST tarsnap-autoconf-1.0.35.tgz 600115 SHA256 6c9f6756bc43bc225b842f7e3a0ec7204e0cf606e10559d27704e1cc33098c9a SHA512 70f932b172717d7f0d6f96a357487b8f8ad13cb7332d73878f629c3abf0862da54a0621092d81ce8cd9eb8380cf5b4c32e89df4d890949429fc84737024dcb61 WHIRLPOOL c6fb8837fd3845aa037bf38852f16e5fbf74fbd5f8cf9581e86f595b30a02d7d2784db781c2ef3771da83373d4ec9d6a93e8c7d9970a68ad052dcfdb7d79c8fc
+DIST tarsnap-autoconf-1.0.37.tgz 629450 SHA256 fa999413651b3bd994547a10ffe3127b4a85a88b1b9a253f2de798888718dbfa SHA512 050053f2109b74cda16511cf35ab2c11e0470ba745c661d254b7c17efde9e629830d519896b343dbd4f48ee739dfef47b724eb5e2e78c3e7dbc4ae018a536a5f WHIRLPOOL 7a5a3aa6e5a0f6790d1ca4903fbe4dab758c104b1cb713e748721e81aa3305d6d1dea755994468d3b26451441c077362c4a64757c2f4fab552fdd9efba9afaa1
diff --git a/app-backup/tarsnap/tarsnap-1.0.37.ebuild b/app-backup/tarsnap/tarsnap-1.0.37.ebuild
new file mode 100644 (file)
index 0000000..ced04c9
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Online backups for the truly paranoid"
+HOMEPAGE="http://www.tarsnap.com/"
+SRC_URI="https://www.tarsnap.com/download/${PN}-autoconf-${PV}.tgz"
+
+LICENSE="tarsnap"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl bzip2 libressl lzma xattr"
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       sys-libs/e2fsprogs-libs
+       sys-libs/zlib
+       acl? ( sys-apps/acl )
+       bzip2? ( app-arch/bzip2 )
+       lzma? ( app-arch/xz-utils )
+       xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+       virtual/os-headers" # Required for "magic.h"
+
+S=${WORKDIR}/${PN}-autoconf-${PV}
+
+src_configure() {
+       econf \
+               $(use_enable xattr) \
+               $(use_enable acl) \
+               $(use_with bzip2 bz2lib) \
+               --without-lzmadec \
+               $(use_with lzma)
+}
+
+src_install() {
+       default
+       dobashcomp misc/bash_completion.d/*
+}