x11-libs/libdrm: Version bump to 2.4.101
authorMatt Turner <mattst88@gentoo.org>
Sat, 4 Apr 2020 18:54:05 +0000 (11:54 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 4 Apr 2020 18:55:06 +0000 (11:55 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/libdrm/Manifest
x11-libs/libdrm/libdrm-2.4.101.ebuild [new file with mode: 0644]

index 2ed887007a2a179ede1c36fd565375051c0a2c9e..6fefb9e3a4fa0b5cd8f34b3d311144805eb48c81 100644 (file)
@@ -1 +1,2 @@
 DIST libdrm-2.4.100.tar.bz2 855793 BLAKE2B ba2c631de860b8e2a8bb34d8ac0ba2ed11c05cc98a156bb81ffafa0395e22f79878b9936efd1ae33c31049c2a5cc281586a867a974eeb4018dd713a8481ed269 SHA512 4d3a5556e650872944af52f49de395e0ce8ac9ac58530e39a34413e94dc56c231ee71b8b8de9fb944263515a922b3ebbf7ddfebeaaa91543c2604f9bcf561247
+DIST libdrm-2.4.101.tar.xz 408856 BLAKE2B 4b2ab7ecf6c360bbe259913943aadabacdbc4fe2eef72cddced4e2abf830e253230d28c8c2e595f93c20a48813eeeef6eb8d20250a8afe1ddce76c48bfa3988a SHA512 658cfc6f478b674b77b4613e1af9ce8f4fd2ace8a18e75729de254d14b7c1f5d67d4bfdb58744aea74abca0f6521326225f4156bd5cbeeed79ca3e025f657e8c
diff --git a/x11-libs/libdrm/libdrm-2.4.101.ebuild b/x11-libs/libdrm/libdrm-2.4.101.ebuild
new file mode 100644 (file)
index 0000000..46ea35c
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/drm.git"
+
+if [[ ${PV} = 9999* ]]; then
+       GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson multilib-minimal
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/ https://gitlab.freedesktop.org/mesa/drm"
+if [[ ${PV} = 9999* ]]; then
+       SRC_URI=""
+else
+       SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+       IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+       video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       valgrind? ( dev-util/valgrind )"
+
+multilib_src_configure() {
+       local emesonargs=(
+               # Udev is only used by tests now.
+               -Dudev=false
+               -Dcairo-tests=false
+               -Damdgpu=$(usex video_cards_amdgpu true false)
+               -Dexynos=$(usex video_cards_exynos true false)
+               -Dfreedreno=$(usex video_cards_freedreno true false)
+               -Dintel=$(usex video_cards_intel true false)
+               -Dnouveau=$(usex video_cards_nouveau true false)
+               -Domap=$(usex video_cards_omap true false)
+               -Dradeon=$(usex video_cards_radeon true false)
+               -Dtegra=$(usex video_cards_tegra true false)
+               -Dvc4=$(usex video_cards_vc4 true false)
+               -Detnaviv=$(usex video_cards_vivante true false)
+               -Dvmwgfx=$(usex video_cards_vmware true false)
+               -Dlibkms=$(usex libkms true false)
+               # valgrind installs its .pc file to the pkgconfig for the primary arch
+               -Dvalgrind=$(usex valgrind auto false)
+       )
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       meson_src_test
+}
+
+multilib_src_install() {
+       meson_src_install
+}