dev-python/google-api-python-client: Version bump to 1.7.9
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 12 Jul 2019 17:52:02 +0000 (10:52 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 12 Jul 2019 17:52:24 +0000 (10:52 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/google-api-python-client/Manifest
dev-python/google-api-python-client/google-api-python-client-1.7.9.ebuild [new file with mode: 0644]

index c83d94ccb521efb1b30f021d46f2206e31f75f72..8184ae57e92070d140d5cb4c984054557cacac1e 100644 (file)
@@ -2,3 +2,4 @@ DIST google-api-python-client-1.5.3.tar.gz 3622355 BLAKE2B 1187729581c9e852a4512
 DIST google-api-python-client-1.6.2.tar.gz 4262337 BLAKE2B 0ae3e5b1c6bbb80999cfaadaef7812bb53d03eb1160f79a29bf73a180dae40bd2c5e7dceff0badaf5eda44718a06c4ec65fe993896a82c5fd12348f810ec2812 SHA512 ee906c2efb47469dc18dcfcb1edfad4346f61e88c1e7f73b60924b393c704e7033a5ff4f9a1965d0c29aa3a6bf25b60888e1d39366cbc1372861b49e79c9e886
 DIST google-api-python-client-1.6.5.tar.gz 4255929 BLAKE2B 4e2197fe56f25cd202f7a0b3f64b3796158d798bfedb9c0690a59c24bd5ce10fbe0300093ebb76cd343dae5eea2a0a360903cd0890834241926fd55a7dc07ea9 SHA512 b2f2be81e6f54ee3065e75ea064ea3ae49cb983d401ac46dca8459409dbd6df7c3ba07798285b5177bfa632a20d43aaaef3a7c73d5d565796567b8b305737565
 DIST google-api-python-client-1.7.0.tar.gz 4259363 BLAKE2B 0a6129e5cfa002095c18eb17c28b8f576f69c6aefa20cb752ce1b529cf5c6ba63f9d213cecb34340fd8224387c7d06c8ad3b4f493e32d26afd14e8e12b4c7ded SHA512 3dc0323ec8816725cc46ad75735b81c2b1e97d1dfc8964f9852f8f739dcdeffffcec461deb7e77b759d66b1e711ffcd948ae45df1e870cef9d6966ebfd793a40
+DIST google-api-python-client-1.7.9.tar.gz 4142239 BLAKE2B 1754162cd7ae5aa64e105e4842ac415473949064576241453ba5aefcc9c53e3a070167d4210f49509a5f63d4b9e79fa5377119ccd53acafe24eaad4a39e5f8c7 SHA512 1e4410c5e639a6bd3cf12b3e648a63e0098182bb52196085dc92597a38e98984fd349adc282d688aa58ec263502d984f54c7827b7ce53128811e7137234358b6
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.7.9.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.7.9.ebuild
new file mode 100644 (file)
index 0000000..6d8fc40
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
+       <dev-python/httplib2-1[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/google-auth-1.4.1[${PYTHON_USEDEP}]
+       >=dev-python/google-auth-httplib2-0.0.3[${PYTHON_USEDEP}]
+       >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
+       <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+       <dev-python/six-2[${PYTHON_USEDEP}]
+       "
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/unittest2[${PYTHON_USEDEP}]
+       )"
+
+python_prepare_all() {
+       export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       nosetests --verbosity=3 || die
+}