sys-libs/glibc: Disable sandbox in test phase, it breaks too much
authorAndreas K. Huettel <dilfridge@gentoo.org>
Sun, 22 Mar 2020 10:38:37 +0000 (11:38 +0100)
committerAndreas K. Huettel <dilfridge@gentoo.org>
Sun, 22 Mar 2020 10:39:23 +0000 (11:39 +0100)
Acked by Sergei (slyfox)

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
sys-libs/glibc/glibc-9999.ebuild

index fc5b12bfb5e9b521b3d38a79d7c9ec76bc7bb901..a2c3812e254ed41c01a3df536a9f62df782061d8 100644 (file)
@@ -135,15 +135,7 @@ GENTOO_GLIBC_XFAIL_TESTS="${GENTOO_GLIBC_XFAIL_TESTS:-yes}"
 # The following tests fail due to the Gentoo build system and are thus
 # executed but ignored:
 XFAIL_TEST_LIST=(
-       # 1) Sandbox
-       tst-ldconfig-bad-aux-cache
-       tst-pldd
-       tst-mallocfork2
-       tst-nss-db-endgrent
-       tst-nss-db-endpwent
-       tst-nss-files-hosts-long
-       tst-nss-test3
-       # 2) Namespaces and cgroup
+       # 1) Namespaces and cgroup
        tst-locale-locpath
        # 9) Failures of unknown origin
        tst-latepthread
@@ -1167,14 +1159,10 @@ glibc_src_test() {
                done
        fi
 
-       # disable tests:
-       # - tests-container:
-       #     sandbox does not understand unshare() and prevents
-       #     writes to /proc/
-       # emake ${myxfailparams} check tests-container=
-       # if possible let's list them (unless it's *all* container tests)
+       # sandbox does not understand unshare() and prevents
+       # writes to /proc/, which makes many tests fail
 
-       emake ${myxfailparams} check
+       SANDBOX_ON=0 LD_PRELOAD= emake ${myxfailparams} check
 }
 
 do_src_test() {