app-emulation/qemu: use pax-mark "mr" instead of pax-mark "m", bug #575594
authorMatthias Maier <tamiko@gentoo.org>
Thu, 9 Mar 2017 19:06:23 +0000 (13:06 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Thu, 9 Mar 2017 19:08:21 +0000 (13:08 -0600)
Package-Manager: Portage-2.3.3, Repoman-2.3.2

app-emulation/qemu/qemu-2.8.0-r7.ebuild
app-emulation/qemu/qemu-9999.ebuild

index 4e09e1aca5f505ea0a0755bbcdbd9eb5b2ae8dee..2088438d8e587a40893e3acc010532fbbc252cba 100644 (file)
@@ -678,7 +678,7 @@ src_install() {
 
        # Disable mprotect on the qemu binaries as they use JITs to be fast #459348
        pushd "${ED}"/usr/bin >/dev/null
-       pax-mark m "${softmmu_bins[@]}" "${user_bins[@]}"
+       pax-mark mr "${softmmu_bins[@]}" "${user_bins[@]}" # bug 575594
        popd >/dev/null
 
        # Install config file example for qemu-bridge-helper
index 5e9a34ada3b00136bf1068fdd9063880e9494ab7..c208a1d924bb5dff053dc8c60b9e71581d03fdf6 100644 (file)
@@ -657,7 +657,7 @@ src_install() {
 
        # Disable mprotect on the qemu binaries as they use JITs to be fast #459348
        pushd "${ED}"/usr/bin >/dev/null
-       pax-mark m "${softmmu_bins[@]}" "${user_bins[@]}"
+       pax-mark mr "${softmmu_bins[@]}" "${user_bins[@]}" # bug 575594
        popd >/dev/null
 
        # Install config file example for qemu-bridge-helper