dev-util/mdds: Update live ebuild
authorNils Freydank <holgersson@posteo.de>
Mon, 2 Mar 2020 22:24:27 +0000 (23:24 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 16 Mar 2020 21:25:43 +0000 (22:25 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Nils Freydank <holgersson@posteo.de>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-util/mdds/mdds-9999.ebuild

index 2709004f0637e9676ce8f079de71b19124e49e3d..37717bcfe9a53df4321f1b57a037abd993d9e2ba 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
        EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
        inherit git-r3
 else
@@ -17,7 +17,8 @@ HOMEPAGE="https://gitlab.com/mdds/mdds"
 
 LICENSE="MIT"
 SLOT="1/${PV%.*}"
-IUSE="doc valgrind"
+IUSE="doc valgrind test"
+RESTRICT="!test? ( test )"
 
 BDEPEND="
        doc? (
@@ -29,22 +30,24 @@ BDEPEND="
 DEPEND="dev-libs/boost:="
 RDEPEND="${DEPEND}"
 
-PATCHES=( "${FILESDIR}/${PN}-1.4.3-buildsystem.patch" )
+PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
 
 src_prepare() {
        default
+
        eautoreconf
 }
 
 src_configure() {
-       econf \
-               $(use_enable doc docs) \
+       local myeconfargs=(
+               $(use_enable doc docs)
                $(use_enable valgrind memory_tests)
+       )
+       econf "${myeconfargs[@]}"
 }
 
-src_compile() { :; }
-
 src_test() {
        tc-export CXX
+
        default
 }