dev-lang/gprolog: work around GCC10 (-fno-common) build failures
authorKeri Harris <keri@gentoo.org>
Thu, 28 May 2020 11:01:00 +0000 (13:01 +0200)
committerKeri Harris <keri@gentoo.org>
Thu, 28 May 2020 11:01:22 +0000 (13:01 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Keri Harris <keri@gentoo.org>
dev-lang/gprolog/gprolog-1.4.5.ebuild

index 0e9c8c9758961fb033bc0ea3f38e46c259530400..0a47ce2d34c464bde9461d946e1317198e8e1255 100644 (file)
@@ -31,6 +31,9 @@ src_prepare() {
 src_configure() {
        CFLAGS_MACHINE="`get-flag -march` `get-flag -mcpu` `get-flag -mtune`"
 
+       # Work around -fno-common ( GCC10 default ), bug #71202
+       append-flags -fcommon
+
        append-flags -fno-strict-aliasing
        use debug && append-flags -DDEBUG