dev-libs/libdivecomputer: version bump, port to EAPI 7
authorMartin Gysel <me@bearsh.org>
Sat, 26 Oct 2019 18:29:03 +0000 (20:29 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 1 Nov 2019 14:06:44 +0000 (16:06 +0200)
remove tools useflag

Closes: https://bugs.gentoo.org/696526
Signed-off-by: Martin Gysel <me@bearsh.org>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/libdivecomputer/Manifest
dev-libs/libdivecomputer/libdivecomputer-0.6.0.ebuild [new file with mode: 0644]
dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
dev-libs/libdivecomputer/metadata.xml

index 86e2bf795ade7f76ab907496b366ed3efd3619a4..4a370131edc28f27470abc3fc0b38084644b72da 100644 (file)
@@ -1,2 +1,3 @@
 DIST libdivecomputer-0.4.1.tar.gz 481798 BLAKE2B c4e132087f833dabc8504cd2cdacfe2c5fb29c208855d799cbb095a1ac3c75e7562136a5d47a8ff5717fa7241eec2114812c3c854cb950e0260f9111f873ad9d SHA512 a1104981b1820ea93c3b3e389e42996f9199c5a4c37daf16e9577d8fd29b21440521d1ea5f89ec2df2861b582fd2e748d35eb811ad0d484eacce7d13d39bf88f
 DIST libdivecomputer-0.4.2.tar.gz 487401 BLAKE2B fb6abdf8ac4a6bc4ab121dfcf4e898aed65a3ab7e8692c4a9525c46e3f7c890eeeac88d4903d7192752175f7c964fd0135cf1d119ffc2a49d572e4abf72d906f SHA512 590aca350d86d17a889f47238ad46f0a6a1353b5f7ed67c64a9bae303a010ab042e94a73a36c6f05f2d03d10c80b1fae49431ad581b3024db83b81711d5d1048
+DIST libdivecomputer-0.6.0.tar.gz 680425 BLAKE2B 9ed951c6cdec07929ea7a9d3b842483ea1c88bff0171bfec1ec5a1a1d21a73580f70034856c97397bd21061d01967e14477ffabdf75b10bd6a736820b17e5b7f SHA512 b199d3e7e89fb2f79e4de5b54b086ae5f8b6bc08d02513e903e8fb008c1a453cf4cd4c4b7a94b1f7053ac53cc7b9085193b0ee0682318594c27ac2cb693c9b3f
diff --git a/dev-libs/libdivecomputer/libdivecomputer-0.6.0.ebuild b/dev-libs/libdivecomputer/libdivecomputer-0.6.0.ebuild
new file mode 100644 (file)
index 0000000..9f8a7f6
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+if [[ ${PV} = *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/libdivecomputer/libdivecomputer"
+       inherit autotools git-r3
+else
+       SRC_URI="https://www.libdivecomputer.org/releases/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Library for communication with dive computers from various manufacturers."
+HOMEPAGE="https://www.libdivecomputer.org"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+IUSE="bluetooth"
+
+RDEPEND="virtual/libusb:1
+       bluetooth? ( net-wireless/bluez )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+src_prepare() {
+       default
+       [[ -v EGIT_REPO_URI ]] && eautoreconf
+}
+
+src_configure() {
+       econf $(use_with bluetooth bluez)
+}
index 05e2cc29858a8999e628e95fc10f6a153cd17927..9f8a7f678342e69b1e7138f47a81076371eccef0 100644 (file)
@@ -1,62 +1,33 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
+EAPI="7"
 
 if [[ ${PV} = *9999* ]]; then
-       EGIT_REPO_URI="git://git.libdivecomputer.org/libdivecomputer.git"
-       GIT_ECLASS="git-2"
-       AUTOTOOLS_AUTORECONF=1
-       KEYWORDS=""
+       EGIT_REPO_URI="https://github.com/libdivecomputer/libdivecomputer"
+       inherit autotools git-r3
 else
+       SRC_URI="https://www.libdivecomputer.org/releases/${P}.tar.gz"
        KEYWORDS="~amd64 ~x86"
 fi
 
-AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit eutils autotools-utils ${GIT_ECLASS}
-
-if [[ ${PV} = *9999* ]]; then
-       SRC_URI=""
-else
-       SRC_URI="http://www.divesoftware.org/libdc/releases/${P}.tar.gz"
-fi
-
-DESCRIPTION="Library for communication with dive computers from various manufacturers"
-HOMEPAGE="http://www.divesoftware.org/libdc"
+DESCRIPTION="Library for communication with dive computers from various manufacturers."
+HOMEPAGE="https://www.libdivecomputer.org"
 LICENSE="LGPL-2.1"
 
 SLOT="0"
-IUSE="usb +static-libs -tools"
+IUSE="bluetooth"
 
-RDEPEND="usb? ( virtual/libusb:1 )"
+RDEPEND="virtual/libusb:1
+       bluetooth? ( net-wireless/bluez )"
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
-src_configure() {
-       autotools-utils_src_configure
-
-       if ! use tools ; then
-               sed -i 's|examples||' Makefile || die "sed failed"
-       fi
+src_prepare() {
+       default
+       [[ -v EGIT_REPO_URI ]] && eautoreconf
 }
 
-src_install() {
-       autotools-utils_src_install
-
-       if use tools ; then
-               einfo "prefixing tools with 'dctool_'"
-               pushd "${D}/usr/bin/"
-               for file in * ; do
-                       mv "${file}" "dctool_${file}" || die "prefixing tools failed"
-               done
-               popd
-       fi
-}
-
-pkg_postinst() {
-       if use tools ; then
-               elog "The 'tools' USE flag has been enabled,"
-               elog "to avoid file collisions, all ${PN}"
-               elog "related tools have been prefixed with 'dctool_'"
-       fi
+src_configure() {
+       econf $(use_with bluetooth bluez)
 }
index 93908aedd9582eeece6be59970be319faef8a4a8..f4838fd208b44d326cc53ede05a33f795527162e 100644 (file)
@@ -12,7 +12,4 @@
        <longdescription lang="en">
                Library for communication with dive computers from various manufacturers.
        </longdescription>
-       <use>
-               <flag name="tools">Install tools that can be used to test the library.</flag>
-       </use>
 </pkgmetadata>