www-apache/passenger: add 5.3.1
authorHans de Graaff <graaff@gentoo.org>
Wed, 16 May 2018 06:00:17 +0000 (08:00 +0200)
committerHans de Graaff <graaff@gentoo.org>
Wed, 16 May 2018 06:01:02 +0000 (08:01 +0200)
Package-Manager: Portage-2.3.36, Repoman-2.3.9

www-apache/passenger/Manifest
www-apache/passenger/passenger-5.3.1.ebuild [new file with mode: 0644]

index 2470d4811099d54e3fc94ac3295b15ce6b5214a6..79740cf155bbb2db196b99dbec0ae13105d4cb16 100644 (file)
@@ -1,3 +1,4 @@
 DIST passenger-5.1.12.tar.gz 4245993 BLAKE2B 4f5808bcb373a85fbe2e160d9bd993fdff32a78f5083f5b5ff38112a4d3ca906a18a241cef6744350c0f33ef357dfda7a2cd5af875223a082a19b4e99cba4aeb SHA512 7ecdf0be306a3c4b842c8497861dbc072fc87f5601840678fe1125b77d50e683003b49616397d39b34705c967f604f5193be173c52a9c5ab235ef4e6e43f2f4a
 DIST passenger-5.2.3.tar.gz 6956101 BLAKE2B c2c5448f330e0bd90b5378e9868c18999263428df0a396595f4793979d3961282743b04eaec78b2cf5a0ebdb6a8183b798c2ae244b8a033edf14f5b8837225ca SHA512 fcd2244a30ce633f83448ff2fe3eea4d2215aa061aaf66de2dcd27f0b440b782d051f0f1ca49d6db673871e31518dc95cc6ffbd48a020f8ffe927d3b5969ef97
 DIST passenger-5.3.0.tar.gz 7033231 BLAKE2B 5cfbd86153e0715b7ac2082ec56dda1e104fd297912dfdd9d8313fd95cb3e52c47360001dfabcc2e88e7cb4f357813fd9e7f51d4ebf94a607183eccbe9b158d1 SHA512 4e3516c21776b9451301f134ffc34ac2dc77f2462329c2655fd3348317fdf0e4f8c6720fd1e676693006b31722c198443219848b04b7a08deaf7ef088052b1eb
+DIST passenger-5.3.1.tar.gz 7033258 BLAKE2B 74269e06fefdc597344ddd5f11fb800df9beba7f59bfb3d0b43069f941d82db09cc6129bafdefd2175bf231ed496e7eb0298e500b27129da1ee07a04d054a8ad SHA512 973338f934a1fc484058cf15748695129ab7ddb8c0d4d8527100fefd111a0b794d60b2e59f8f494c4ef5703c72c7ebfeef5539ed9b4a6e736114e2077e83ccdd
diff --git a/www-apache/passenger/passenger-5.3.1.ebuild b/www-apache/passenger/passenger-5.3.1.ebuild
new file mode 100644 (file)
index 0000000..7a2b4ba
--- /dev/null
@@ -0,0 +1,127 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
+
+DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
+HOMEPAGE="https://www.phusionpassenger.com/"
+SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="apache2 debug"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+ruby_add_rdepend "
+       >=dev-ruby/rack-1.0.0:*
+       >=dev-ruby/rake-0.8.1"
+
+# libev is bundled but with adapations that do not seem to be accepted
+# upstream, so we must use the bundled version :-(
+CDEPEND="
+       >=dev-libs/libuv-1.8.0
+       net-misc/curl[ssl]
+       apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
+
+RDEPEND="${RDEPEND} ${CDEPEND}"
+DEPEND="${DEPEND} ${CDEPEND}"
+
+APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
+APACHE2_MOD_DEFINE="PASSENGER"
+
+want_apache2
+
+pkg_setup() {
+       use debug && append-flags -DPASSENGER_DEBUG
+       depend.apache_pkg_setup
+}
+
+all_ruby_prepare() {
+       epatch "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
+       eapply "${FILESDIR}"/${PN}-5.1.1-isnan.patch
+
+       # Change these with sed instead of a patch so that we can easily use
+       # the toolchain-funcs methods.
+       sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
+               -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
+               -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
+
+       # Avoid fixed debugging CFLAGs.
+       sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
+
+       # Use sed here so that we can dynamically set the documentation directory.
+       sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
+               -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
+               src/ruby_supportlib/phusion_passenger.rb || die
+       sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
+
+       # Don't install a tool that won't work in our setup.
+       sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
+       rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
+
+       # Make sure we use the system-provided version where possible
+       rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
+
+       # Avoid building documentation to avoid a dependency on mizuho.
+       #sed -i -e 's/, :doc//' build/packaging.rb || die
+       touch doc/*.html || die
+
+       # Fix hard-coded use of AR
+       sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
+
+       # Make sure apache support is not attempted with -apache2
+       if ! use apache2 ; then
+               sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
+       fi
+}
+
+all_ruby_compile() {
+       if use apache2 ; then
+               V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
+                APXS2="${APXS}" \
+                HTTPD="${APACHE_BIN}" \
+                FS_LIBDIR='/usr/'$(get_libdir) \
+                USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+                ruby -S rake apache2 || die "rake failed"
+       fi
+}
+
+each_ruby_compile() {
+       append-flags -fno-strict-aliasing
+
+       V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
+       APXS2="${APXS}" \
+       HTTPD="${APACHE_BIN}" \
+       FS_LIBDIR='/usr/'$(get_libdir) \
+       USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+       ${RUBY} -S rake native_support || die "rake failed"
+}
+
+all_ruby_install() {
+       if use apache2 ; then
+               APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
+               apache-module_src_install
+
+               # Patch in the correct libdir
+               sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
+       fi
+
+       dodoc CHANGELOG README.md
+}
+
+each_ruby_install() {
+       DISTDIR="${D}" \
+       RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
+       RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
+       APXS2="${APXS}" \
+       HTTPD="${APACHE_BIN}" \
+       FS_LIBDIR='/usr/'$(get_libdir) \
+       EXTRA_LDFLAGS="${LDFLAGS}" \
+       USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+       ${RUBY} -S rake fakeroot || die "rake failed"
+}