Version bump.
authorAndrej Kacian <ticho@gentoo.org>
Mon, 9 Oct 2006 23:05:58 +0000 (23:05 +0000)
committerAndrej Kacian <ticho@gentoo.org>
Mon, 9 Oct 2006 23:05:58 +0000 (23:05 +0000)
Package-Manager: portage-2.1.2_pre2-r5

net-mail/fetchmail/ChangeLog
net-mail/fetchmail/fetchmail-6.3.5.ebuild [new file with mode: 0644]
net-mail/fetchmail/files/digest-fetchmail-6.3.5 [new file with mode: 0644]

index bf7598b454583b673e98fffb6ffc027ee0150cb5..405d3250a2ccf282647e5b758e9977e2559770e9 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-mail/fetchmail
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.108 2006/10/09 21:27:49 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.109 2006/10/09 23:05:58 ticho Exp $
+
+*fetchmail-6.3.5 (09 Oct 2006)
+
+  09 Oct 2006; <ticho@gentoo.org> +fetchmail-6.3.5.ebuild:
+  Version bump.
 
   09 Oct 2006; Timothy Redaelli <drizzt@gentoo.org> fetchmail-6.3.4.ebuild:
   Added ~x86-fbsd keyword.
diff --git a/net-mail/fetchmail/fetchmail-6.3.5.ebuild b/net-mail/fetchmail/fetchmail-6.3.5.ebuild
new file mode 100644 (file)
index 0000000..bdf6e89
--- /dev/null
@@ -0,0 +1,92 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.5.ebuild,v 1.1 2006/10/09 23:05:58 ticho Exp $
+
+inherit eutils gnuconfig
+
+FCONF_P="fetchmailconf-1.43.2"
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="http://download2.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
+~x86-fbsd"
+IUSE="ssl nls ipv6 kerberos krb4 hesiod"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+       ssl? ( >=dev-libs/openssl-0.9.6 )
+       kerberos? ( app-crypt/mit-krb5 )
+       nls? ( sys-devel/gettext )
+       elibc_FreeBSD? ( sys-libs/com_err )"
+
+DEPEND="${RDEPEND}
+       sys-devel/autoconf"
+
+src_unpack() {
+       unpack ${A} || die "unpack failed"
+       cd ${S} || die "cd \${S} failed"
+
+       # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+       epatch ${FILESDIR}/${PN}-6.2.5-broken-headers.patch || die
+
+       autoconf
+       gnuconfig_update
+}
+
+src_compile() {
+       econf  --disable-dependency-tracking \
+               --enable-RPA \
+               --enable-NTLM \
+               --enable-SDPS \
+               $(use_enable nls) \
+               $(use_enable ipv6 inet6) \
+               $(use_with kerberos gssapi) $(use_with kerberos kerberos5) \
+               $(use_with krb4 kerberos) \
+               $(use_with ssl) \
+               $(use_with hesiod) \
+               ${myconf} || die "Configuration failed."
+       # wont compile reliably on smp (mkennedy@gentoo.org 2003-11-12)
+       emake || die "Compilation failed."
+}
+
+src_install() {
+       einstall || die
+
+       dohtml *.html
+
+       dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+               README.NTLM README.SSL TODO COPYING
+
+       doman ${D}/usr/share/man/*.1
+       rm -f ${D}/usr/share/man/*.1
+
+       newinitd ${FILESDIR}/fetchmail fetchmail
+       newconfd ${FILESDIR}/conf.d-fetchmail fetchmail
+
+       docinto contrib
+       local f
+       for f in contrib/*
+       do
+               [ -f "${f}" ] && dodoc "${f}"
+       done
+}
+
+pkg_postinst() {
+       if ! python -c "import Tkinter" >/dev/null 2>&1
+       then
+               einfo
+               einfo "You will not be able to use fetchmailconf(1), because you"
+               einfo "don't seem to have Python with tkinter support."
+               einfo
+               einfo "If you want to be able to use fetchmailconf(1), do the following:"
+               einfo "  1.  Add 'tk' to the USE variable in /etc/make.conf."
+               einfo "  2.  (Re-)merge Python."
+               einfo
+       fi
+
+       einfo "Please see /etc/conf.d/fetchmail if you want to adjust"
+       einfo "the polling delay used by the fetchmail init script."
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.3.5 b/net-mail/fetchmail/files/digest-fetchmail-6.3.5
new file mode 100644 (file)
index 0000000..25509b9
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 e8dc5cd8e80677bb60e397d6171d12ec fetchmail-6.3.5.tar.bz2 1237821
+RMD160 3032622b8e3d2171bc7d94357414ccc69bfa9f0d fetchmail-6.3.5.tar.bz2 1237821
+SHA256 0af641629fc1b7ee2561eccd5ecd0efea20fea935656d155886061c530114f2b fetchmail-6.3.5.tar.bz2 1237821