dev-python/pytest-cov: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 18:30:38 +0000 (19:30 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 18:48:22 +0000 (19:48 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-cov/pytest-cov-2.8.1.ebuild

index 1e4b3ea6f1409500c3624101473d5392d2093ef4..2c1f3a751897db42c029cfce8568505087bb1c6f 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
 
 inherit distutils-r1
@@ -23,7 +24,6 @@ RDEPEND="
        >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
 "
 DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/virtualenv[${PYTHON_USEDEP}]
                dev-python/fields[${PYTHON_USEDEP}]