dev-ml/astring: initial import; ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 07:30:23 +0000 (08:30 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 09:15:48 +0000 (10:15 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/astring/Manifest [new file with mode: 0644]
dev-ml/astring/astring-0.8.3.ebuild [new file with mode: 0644]
dev-ml/astring/metadata.xml [new file with mode: 0644]

diff --git a/dev-ml/astring/Manifest b/dev-ml/astring/Manifest
new file mode 100644 (file)
index 0000000..ba30292
--- /dev/null
@@ -0,0 +1 @@
+DIST astring-0.8.3.tbz 38710 SHA256 206646340d86ffcca900d0a3fbded2140c0efc4b74a84f84dc92667a07e3b247 SHA512 c7230e47b7ef14e6040fb18284a3d5aa8da1428b721cf91a7f17104cfb853be24b9c2aaa0b118bf3e050158aa8748311435417c6cf9014d260fb4379e4ead3e1 WHIRLPOOL 433897bd4e1d3e58424fbc7e7914a89164aab22ec7c2a77befd449ba2e557fbdbe495995485621afcdee69291f43a12d382a9ab26622812cb9b80d082bf7f5c9
diff --git a/dev-ml/astring/astring-0.8.3.ebuild b/dev-ml/astring/astring-0.8.3.ebuild
new file mode 100644 (file)
index 0000000..be3d4ff
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Alternative String module for OCaml"
+HOMEPAGE="http://erratique.ch/software/astring https://github.com/dbuenzli/astring"
+SRC_URI="http://erratique.ch/software/astring/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}
+       dev-ml/opam
+       dev-ml/topkg
+       dev-ml/ocamlbuild
+       dev-ml/findlib"
+
+src_compile() {
+       ocaml pkg/pkg.ml build || die
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md README.md
+}
diff --git a/dev-ml/astring/metadata.xml b/dev-ml/astring/metadata.xml
new file mode 100644 (file)
index 0000000..ffac4d7
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>