dev-java/icedtea: re-add mincoming-stack-boundary=2 on x86
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 3 Feb 2019 11:52:56 +0000 (03:52 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 3 Feb 2019 22:10:46 +0000 (14:10 -0800)
it was lost on bump
Bug: https://bugs.gentoo.org/677138
Package-Manager: Portage-2.3.59, Repoman-2.3.12
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/icedtea/icedtea-3.10.0.ebuild

index c47e7ca17b5bb287cac111820413b64e52ebbc3f..9dafe7d9ab91c9da6c1e67a97820a3f3f2740d0e 100644 (file)
@@ -10,7 +10,7 @@
 EAPI="6"
 SLOT="8"
 
-inherit check-reqs gnome2-utils java-pkg-2 java-vm-2 multiprocessing pax-utils prefix versionator
+inherit check-reqs flag-o-matic gnome2-utils java-pkg-2 java-vm-2 multiprocessing pax-utils prefix versionator
 
 ICEDTEA_VER=$(get_version_component_range 1-3)
 ICEDTEA_BRANCH=$(get_version_component_range 1-2)
@@ -233,6 +233,9 @@ src_configure() {
        # In-tree JIT ports are available for amd64, arm, arm64, ppc64 (be&le), SPARC and x86.
        if { use amd64 || use arm || use arm64 || use ppc64 || use sparc || use x86; }; then
                hotspot_port="yes"
+
+               # Work around stack alignment issue, bug #647954.
+               use x86 && append-flags -mincoming-stack-boundary=2
        fi
 
        # Always use HotSpot as the primary VM if available. #389521 #368669 #357633 ...