media-plugins/gst-plugins-v4l2: bump to 1.14.4, no code changes from 1.14.3
authorMart Raudsepp <leio@gentoo.org>
Wed, 3 Oct 2018 23:42:15 +0000 (02:42 +0300)
committerMart Raudsepp <leio@gentoo.org>
Wed, 3 Oct 2018 23:42:15 +0000 (02:42 +0300)
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

media-plugins/gst-plugins-v4l2/Manifest
media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-1.14.4.ebuild [new file with mode: 0644]

index 9a2e1aa91671e8658e8834bdbea508eadce0180d..9fa13a531a6846ca43e3410bf2c492489431a676 100644 (file)
@@ -2,3 +2,4 @@ DIST gst-plugins-good-0.10.31.tar.xz 2738016 BLAKE2B a015ef6993078f1c699badcc991
 DIST gst-plugins-good-1.14.1.tar.xz 3776168 BLAKE2B 5b17ac49d5bae423ee887f1516ba8bfb542acb17e3f304f489dddbaa728761ee51a08e67bd10a9981f53b5b8424d8013d1723fcbbf6e06d34a39548868d34f85 SHA512 b52d3214f2d32f263637cb9f0838284483e15b8d20bf36d64c349e99b481095734a4dd2c2421176540dfe5129ecc1acc101b89cc898b4773f0f736e8e962b070
 DIST gst-plugins-good-1.14.2.tar.xz 3779912 BLAKE2B d49f82a6be7423d233ec15660470533d6bfc5da3d2ac5912ce7b3f97739b1540424c02593aff269aae3df7c6f15ca37b2d9d45fe85f3b36b910cdac4ba98f093 SHA512 26ff40d949ab95043ed717350fb344a616c72b049cd52c3e7debd9cc37f73eb9d4704b4f437ba257cecb9dba702ce451647279cb821e9405b36210b46ae9aa05
 DIST gst-plugins-good-1.14.3.tar.xz 3790052 BLAKE2B 14f4116ce3eeb20f1f2cc8e835e46a9444ef82291aad90b74e74d0e79c1974bb6f2373f79543a3a3235773c954bd9def67a9e6c64522035fa65e1541695d34e1 SHA512 1077d4ac7332a4bfd58fe5be53104e1404c3a688769520650c030488a184e64a43b301fc1f1d687de668143f849a23cb0ba2b417cf284d20710b9cf32d792e45
+DIST gst-plugins-good-1.14.4.tar.xz 3792524 BLAKE2B 4c7faac73d33bebe1fd53dc4cfed1a5d27b103f9c4cd801672ad52e385f09addb07cd4a0f511dff23815e3421e5202fb3d7866b7dd58fdaf101d0357c4fdc13f SHA512 30aeb3bb74571287cad1598973da38e7a43a0128d35480ded6d280c1373dc4ecd4ea76caaa04a71cdfba2e1850aee5f1b72d96be86ae92d66633e7d32081c504
diff --git a/media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-1.14.4.ebuild b/media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-1.14.4.ebuild
new file mode 100644 (file)
index 0000000..cc0c150
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer
+
+DESCRIPION="V4L2 source/sink plugin for GStreamer"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="udev"
+
+RDEPEND="
+       >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}]
+       >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+       udev? ( >=virtual/libgudev-208:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+       virtual/os-headers
+"
+
+GST_PLUGINS_BUILD="gst_v4l2"
+
+multilib_src_configure() {
+       gstreamer_multilib_src_configure \
+               --with-libv4l2 \
+               $(use_with udev gudev)
+}