media-gfx/opentoonz: Version bump to 1.2.1
authorTact Yoshida <otakuto.gentoo@gmail.com>
Wed, 18 Jul 2018 18:59:44 +0000 (03:59 +0900)
committerTony Vroon <chainsaw@gentoo.org>
Mon, 23 Jul 2018 08:42:20 +0000 (09:42 +0100)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/9276
Closes: https://bugs.gentoo.org/612938

media-gfx/opentoonz/Manifest
media-gfx/opentoonz/files/opentoonz-1.2.1-gcc6-no-throw-in-destructors.patch [new file with mode: 0644]
media-gfx/opentoonz/opentoonz-1.2.1.ebuild [new file with mode: 0644]

index fb7bd6893f29d83ed248c4b7d7337e30df699aa4..19f8c7123f0a365ecf16b28d25e317a5bb6a4dd1 100644 (file)
@@ -1 +1,2 @@
 DIST opentoonz-1.1.2.tar.gz 36777909 BLAKE2B d822218c5ea1843a50da8d799bd9edf6998bd424ec2b65600371a0ae9f69aaea0d1c45aa53c3a0287c67459b8101a82bc0c339510859f4fbac3a116c9671df08 SHA512 800a741cb40e7dede79ef92705fc8fe3a23524c8a4397c30f80a81a7513c98606fb1bb5574188969ba08cfe8995d679f9fc5ecb696a6ac14c48aa2646a2c871e
+DIST opentoonz-1.2.1.tar.gz 39843446 BLAKE2B f9035bab5c6fa1d86459b401ca94acbffe8e38a2f5ec2bc97f303c7e829b9f6695480e7ab7a7560909f6ce45109ca1704d5020ff774964b5ed72b1b01588e93b SHA512 3eaf5983b5ec7424338e25975228b9bf6e9da61b2699c52377528966ecf07971868426bda0a64c780c2876cc1f0e4adb63c46767e8099fbfe32a8d1586c13f44
diff --git a/media-gfx/opentoonz/files/opentoonz-1.2.1-gcc6-no-throw-in-destructors.patch b/media-gfx/opentoonz/files/opentoonz-1.2.1-gcc6-no-throw-in-destructors.patch
new file mode 100644 (file)
index 0000000..ad0e5a2
--- /dev/null
@@ -0,0 +1,38 @@
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=612938
+
+From ae91dbad8c33b35ea564d235c8eba63adfcc0fef Mon Sep 17 00:00:00 2001
+From: Peter-Levine <plevine457@gmail.com>
+Date: Wed, 31 May 2017 04:49:36 -0400
+Subject: [PATCH] Don't allow throw() in destructors (#1182)
+
+---
+ toonz/sources/image/3gp/tiio_3gp_proxy.cpp | 2 --
+ toonz/sources/image/mov/tiio_mov_proxy.cpp | 2 --
+ 2 files changed, 4 deletions(-)
+
+diff --git a/toonz/sources/image/3gp/tiio_3gp_proxy.cpp b/toonz/sources/image/3gp/tiio_3gp_proxy.cpp
+index d1bd79717..03140f695 100644
+--- a/toonz/sources/image/3gp/tiio_3gp_proxy.cpp
++++ b/toonz/sources/image/3gp/tiio_3gp_proxy.cpp
+@@ -138,8 +138,6 @@ TLevelWriter3gp::~TLevelWriter3gp() {
+   QString res;
+   stream << (msg << QString("$closeLW3gp") << m_id);
+-  if (tipc::readMessage(stream, msg) != "ok")
+-    throw TException("Unable to write file");
+ }
+ //------------------------------------------------------------------
+diff --git a/toonz/sources/image/mov/tiio_mov_proxy.cpp b/toonz/sources/image/mov/tiio_mov_proxy.cpp
+index 260bbb196..6be067c01 100644
+--- a/toonz/sources/image/mov/tiio_mov_proxy.cpp
++++ b/toonz/sources/image/mov/tiio_mov_proxy.cpp
+@@ -206,8 +206,6 @@ TLevelWriterMov::~TLevelWriterMov() {
+   QString res;
+   stream << (msg << QString("$closeLWMov") << m_id);
+-  if (tipc::readMessage(stream, msg) != "ok")
+-    throw TException("Unable to write file");
+ }
+ //------------------------------------------------------------------
diff --git a/media-gfx/opentoonz/opentoonz-1.2.1.ebuild b/media-gfx/opentoonz/opentoonz-1.2.1.ebuild
new file mode 100644 (file)
index 0000000..84389a5
--- /dev/null
@@ -0,0 +1,94 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An open-source full-featured 2D animation creation software"
+HOMEPAGE="https://github.com/opentoonz/opentoonz"
+SRC_URI="https://github.com/opentoonz/opentoonz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD libtiff"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       app-arch/lz4:=
+       >=dev-libs/boost-1.55.0:=
+       dev-libs/lzo:2=
+       >=dev-qt/qtcore-5.9:5
+       >=dev-qt/qtgui-5.9:5
+       >=dev-qt/qtmultimedia-5.9:5[widgets]
+       >=dev-qt/qtnetwork-5.9:5
+       >=dev-qt/qtopengl-5.9:5
+       >=dev-qt/qtprintsupport-5.9:5
+       >=dev-qt/qtscript-5.9:5
+       >=dev-qt/qtsvg-5.9:5
+       >=dev-qt/qtwidgets-5.9:5
+       >=dev-qt/qtxml-5.9:5
+       media-libs/freeglut:=
+       media-libs/freetype:2=
+       media-libs/glew:=
+       media-libs/libjpeg-turbo:=
+       >=media-libs/libmypaint-1.3.0
+       media-libs/libpng:=
+       media-libs/libsdl2:=
+       sci-libs/cblas-reference:=
+       >=sci-libs/superlu-4.1:=
+       sys-libs/zlib:=
+       virtual/libusb:=
+       virtual/opengl
+"
+DEPEND="
+       $RDEPEND
+       virtual/pkgconfig
+       dev-qt/linguist-tools:5
+"
+
+CMAKE_USE_DIR="${S}"/toonz/sources
+
+PATCHES=( "${FILESDIR}"/${P}-gcc6-no-throw-in-destructors.patch )
+
+src_configure()
+{
+       local mycmakeargs=(
+               -DTIFF_LIBRARY="${S}/thirdparty/tiff-4.0.3/libtiff/.libs/libtiff.a"
+               -DSUPERLU_INCLUDE_DIR="${EPREFIX%/}/usr/include/superlu"
+               -DLZO_INCLUDE_DIR="${EPREFIX%/}/usr/include/lzo"
+               -DCMAKE_SKIP_RPATH=ON
+       )
+
+       # The upstream uses their own modified libtiff
+       # See: https://github.com/opentoonz/opentoonz/blob/master/doc/how_to_build_linux.md#building-libtiff
+       cd thirdparty/tiff-4.0.3 || die
+       econf \
+               --with-pic \
+               --disable-jbig \
+               --enable-static \
+               --disable-shared
+
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cd "${S}"/thirdparty/tiff-4.0.3 || die
+       emake
+
+       cmake-utils_src_compile
+}
+
+pkg_postinst()
+{
+       elog "It is supposedly optional but some files are"
+       elog "actually required to run the executable properly."
+       elog
+       elog "The .config/OpenToonz/ directory in your home folder"
+       elog "will contain your settings, work and other files."
+       elog
+       elog "We need to create it from the command-line:"
+       elog
+       elog "$ mkdir -p \$HOME/.config/OpenToonz"
+       elog "$ cp -r /usr/share/opentoonz/stuff/ \$HOME/.config/OpenToonz/"
+}