Bug #230245 - Use os.path.basename() on paths returned from `svn list`
authorZac Medico <zmedico@gentoo.org>
Mon, 30 Jun 2008 21:54:20 +0000 (21:54 -0000)
committerZac Medico <zmedico@gentoo.org>
Mon, 30 Jun 2008 21:54:20 +0000 (21:54 -0000)
and `svn status`.

svn path=/main/trunk/; revision=10859

bin/repoman

index 55a8a301f339e82280294b32b26f872f4b5019bf..b0c44ddb1083e44ea441f69ab4c99e70b52d26f3 100755 (executable)
@@ -889,7 +889,7 @@ for x in scanlist:
                                        if l[-1:] == "/":
                                                continue
                                        if l[-7:] == ".ebuild":
-                                               eadded.append(l[:-7])
+                                               eadded.append(os.path.basename(l[:-7]))
                        if vcs == "svn":
                                myf = os.popen("svn status " + checkdir)
                                myl=myf.readlines()
@@ -898,7 +898,7 @@ for x in scanlist:
                                        if l[0] == "A":
                                                l = l.rstrip().split(' ')[-1]
                                                if l[-7:] == ".ebuild":
-                                                       eadded.append(l[:-7])
+                                                       eadded.append(os.path.basename(l[:-7]))
                except IOError:
                        if options.mode == 'commit' and vcs == "cvs":
                                stats["CVS/Entries.IO_error"] += 1