net-im/telegram-desktop: bump to 2.1.1
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 2 May 2020 00:32:17 +0000 (17:32 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 2 May 2020 00:43:01 +0000 (17:43 -0700)
add a warning about ccache not caching build by default
use bundled ms-gsl for now, as we need version 3.0.1 in gentoo

Bug: https://bugs.gentoo.org/715114
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
net-im/telegram-desktop/Manifest
net-im/telegram-desktop/telegram-desktop-2.1.1.ebuild [new file with mode: 0644]

index 027ce25108878c76525563730079eda377c3b577..6587a8402edabdefd06c522a4415a5d6394abfd3 100644 (file)
@@ -1,2 +1,3 @@
 DIST tdesktop-2.0.1-full.tar.gz 26106949 BLAKE2B 3975e7d42af8b323a86408e2301b292d94b308413bb92d135673fb12851cd6672156dcf9b631482fa9b8dc9361d9593dc1104c8c335e0c610706b308414db01b SHA512 99cd7c5ca1e9dd75ecd98d272522b0e4aab2d46525e3d0c306503b7a00c9d25c1646e9d7462182682a58947c7435864af805a3b6f85906d8b21e5675cc8383cb
 DIST tdesktop-2.1.0-full.tar.gz 26133964 BLAKE2B c5eb476ea3ed02c2618e5b770bdce365bcf0d6124f75558570189e07e9dcd9f6f3282d53fec621be736cbd1269a9dd820629d4d9a36167d8f71109bfcd5a52e2 SHA512 46f5453c64d1dbd4cf8adde73fcc48e6b6f795972ab0f6516cb55112f47d5af990a049da356bedb81e6d3f7103c14a7be45369ff9a5a1812c07a1bfcda70646d
+DIST tdesktop-2.1.1-full.tar.gz 26178569 BLAKE2B 377820af9d2ceeab18fa1ca0458803770b9e1cf211ba9bac7f21ae75fcb8e59269ad742c9fc0acd1b6d484d36057c872146cfdba0653bd2461f3a585222cf0b0 SHA512 aa542c029ead2d1b6c398ecca949b86fae8f37094ceb462ace4628f8e53882faf35b3c2e4fe03dd2e4e17b07412896f7b05d6748b13c99a3bac117b7449d69a8
diff --git a/net-im/telegram-desktop/telegram-desktop-2.1.1.ebuild b/net-im/telegram-desktop/telegram-desktop-2.1.1.ebuild
new file mode 100644 (file)
index 0000000..9dad2e7
--- /dev/null
@@ -0,0 +1,145 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake desktop flag-o-matic python-any-r1 xdg-utils
+
+MY_P="tdesktop-${PV}-full"
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="+alsa +dbus enchant +hunspell libressl pulseaudio +spell wayland +X"
+
+RDEPEND="
+       !net-im/telegram-desktop-bin
+       app-arch/lz4:=
+       app-arch/xz-utils
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       dev-cpp/range-v3
+       dev-libs/xxhash
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5[jpeg,png,wayland?,X(-)?]
+       dev-qt/qtimageformats:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtsvg:5
+       dev-qt/qtwidgets:5[png,X(-)?]
+       media-fonts/open-sans
+       media-libs/fontconfig:=
+       >=media-libs/libtgvoip-2.4.4_p20200301[alsa?,pulseaudio?]
+       media-libs/openal[alsa?,pulseaudio?]
+       media-libs/opus:=
+       media-video/ffmpeg:=[alsa?,opus,pulseaudio?]
+       sys-libs/zlib[minizip]
+       virtual/libiconv
+       dbus? (
+               dev-qt/qtdbus:5
+               dev-libs/libdbusmenu-qt[qt5(+)]
+       )
+       enchant? ( app-text/enchant:= )
+       hunspell? ( >=app-text/hunspell-1.7:= )
+       pulseaudio? ( media-sound/pulseaudio )
+"
+
+DEPEND="
+       ${PYTHON_DEPS}
+       ${RDEPEND}
+"
+
+BDEPEND="
+       >=dev-util/cmake-3.16
+       virtual/pkgconfig
+"
+
+REQUIRED_USE="
+       || ( alsa pulseaudio )
+       || ( X wayland )
+       spell? (
+               ^^ ( enchant hunspell )
+       )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+       if has ccache ${FEATURES}; then
+               ewarn
+               ewarn "ccache does not work with ${PN} out of the box"
+               ewarn "due to usage of precompiled headers"
+               ewarn "check bug https://bugs.gentoo.org/715114 for more info"
+               ewarn
+       fi
+}
+
+src_configure() {
+       local mycxxflags=(
+               -Wno-deprecated-declarations
+               -Wno-error=deprecated-declarations
+               -Wno-switch
+       )
+
+       append-cxxflags "${mycxxflags[@]}"
+
+       # TODO: unbundle header-only libs, ofc telegram uses git versions...
+       # it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
+       # EXPECTED VARIANT
+       # TODO: unbundle GSL, version 3.0.1 required and has nasty googletest dep
+       local mycmakeargs=(
+               -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
+               -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
+               -DDESKTOP_APP_USE_PACKAGED=ON
+               -DDESKTOP_APP_USE_PACKAGED_EXPECTED=OFF
+               -DDESKTOP_APP_USE_PACKAGED_GSL=OFF
+               -DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF
+               -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF
+               -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
+               -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
+               -DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)" # enables hunspell (recommended)
+               -DDESKTOP_APP_USE_ENCHANT="$(usex enchant ON OFF)" # enables enchant and disables hunspell
+       )
+
+       if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+               einfo "Found custom API credentials"
+               mycmakeargs+=(
+                       -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+                       -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+               )
+       else
+               # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+               # Building with snapcraft API credentials by default
+               # Custom API credentials can be obtained here:
+               # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+               # After getting credentials you can export variables:
+               #  export MY_TDESKTOP_API_ID="17349""
+               #  export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+               # and restart the build"
+               # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+               # portage will use custom variable every build automatically
+               mycmakeargs+=(
+                       -DTDESKTOP_API_ID="611335"
+                       -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+               )
+       fi
+
+       cmake_src_configure
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}