dev-php/json-schema: bump to 5.2.7
authorTomas Mozes <hydrapolic@gmail.com>
Fri, 7 Sep 2018 11:13:14 +0000 (13:13 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 20 Sep 2018 12:00:17 +0000 (14:00 +0200)
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Package-Manager: Portage-2.3.49, Repoman-2.3.10

dev-php/json-schema/Manifest
dev-php/json-schema/json-schema-5.2.7.ebuild [new file with mode: 0644]

index a0743671c7a6b4a68414aa0f160388960acbb54e..32ad7ad9bccd16869ede6bb939a97d114648bce4 100644 (file)
@@ -1 +1,2 @@
 DIST json-schema-4.1.0.tar.gz 24772 BLAKE2B 181c584c11113c2e0bb7b2f19ef40ae588e470169a4498a47fbd3fcae60d7bb1bb21ac4ab82ce295e487098719fca9004090142d992a296a1b5599fb909b0171 SHA512 5c6bda8c34012bc20d9bf604a6183d50f451327bded70d94415450d2b3cc8e7f6f416ddd8b13db0aeb487fe031fe3185aebd9c97e4c1f79c866dcbc3463f64d0
+DIST json-schema-5.2.7.tar.gz 31388 BLAKE2B b0ce5a9f958effe7d8040c57501841225865eee0d67f56d0eec6aca0c93557b526d51ae35d04a5bd2c066066c1ccdfb00954e6aed866c6d225260ca4a5f73f56 SHA512 fe3b436ea3c29719244fb29e11c37b505fa46845704b9153b1e195147c0b3da39d5d69c61e1b2d89de1ef56bfd51be3552e91cc5dd41a08a8a036e62c29ba197
diff --git a/dev-php/json-schema/json-schema-5.2.7.ebuild b/dev-php/json-schema/json-schema-5.2.7.ebuild
new file mode 100644 (file)
index 0000000..abb217d
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="PHP implementation of JSON schema"
+HOMEPAGE="https://github.com/justinrainbow/json-schema"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# Tests are not in the release tarball
+RESTRICT="test"
+
+RDEPEND="
+       dev-lang/php:*
+       dev-php/fedora-autoloader"
+DEPEND="
+       test? (
+               ${RDEPEND}
+               dev-php/phpunit )"
+
+src_prepare() {
+       default
+       if use test; then
+               cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+       fi
+}
+
+src_install() {
+       insinto "/usr/share/php/JsonSchema"
+       doins -r src/JsonSchema/. "${FILESDIR}"/autoload.php
+       dodoc README.md
+}
+
+src_test() {
+       phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}