projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
37f46e3
)
dev-python/webob: Port to py39
author
Michał Górny
<mgorny@gentoo.org>
Tue, 26 May 2020 18:29:00 +0000
(20:29 +0200)
committer
Michał Górny
<mgorny@gentoo.org>
Tue, 26 May 2020 18:31:55 +0000
(20:31 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/webob/webob-1.8.6.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/webob/webob-1.8.6.ebuild
b/dev-python/webob/webob-1.8.6.ebuild
index fb89754dfce00a9abd037180f2e70f47bd7fbadc..0be6b5b7041f4680515e55ceec3233de3c8e4e30 100644
(file)
--- a/
dev-python/webob/webob-1.8.6.ebuild
+++ b/
dev-python/webob/webob-1.8.6.ebuild
@@
-3,7
+3,7
@@
EAPI=7
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8
,9
}} )
inherit distutils-r1
@@
-21,3
+21,9
@@
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~a
distutils_enable_sphinx docs 'dev-python/alabaster'
distutils_enable_tests pytest
+
+src_prepare() {
+ # py3.9
+ sed -i -e 's:isAlive:is_alive:' tests/conftest.py || die
+ distutils-r1_src_prepare
+}