net-proxy/squidguard-1.6.0: fix building with -fno-common
authorSergey Popov <pinkbyte@gentoo.org>
Sun, 8 Mar 2020 17:23:26 +0000 (20:23 +0300)
committerSergey Popov <pinkbyte@gentoo.org>
Sun, 8 Mar 2020 17:24:44 +0000 (20:24 +0300)
Closes: https://bugs.gentoo.org/708420
Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Package-Manager: Portage-2.3.89, Repoman-2.3.11

net-proxy/squidguard/files/squidguard-1.6.0-gcc-10.patch [new file with mode: 0644]
net-proxy/squidguard/squidguard-1.6.0.ebuild

diff --git a/net-proxy/squidguard/files/squidguard-1.6.0-gcc-10.patch b/net-proxy/squidguard/files/squidguard-1.6.0-gcc-10.patch
new file mode 100644 (file)
index 0000000..650153f
--- /dev/null
@@ -0,0 +1,54 @@
+--- a/src/y.tab.c.bison        2020-03-08 20:05:00.750000000 +0300
++++ b/src/y.tab.c.bison        2020-03-08 20:04:42.160000000 +0300
+@@ -217,7 +217,7 @@
+ #include "sgEx.h"
+-FILE *yyin, *yyout;
++extern FILE *yyin, *yyout;
+ char *configFile;
+ int numTimeElements;
+--- a/src/sg.h.in      2020-03-08 20:02:46.900000000 +0300
++++ b/src/sg.h.in      2020-03-08 20:03:22.110000000 +0300
+@@ -115,7 +115,7 @@
+ #define REDIRECT_PERMANENT   "301:"
+ #define REDIRECT_TEMPORARILY "302:"
+-char *progname;
++extern char *progname;
+ struct LogFileStat {
+   char *name;
+@@ -337,7 +337,7 @@
+   struct AclDest *next;
+ };
+-int lineno;
++extern int lineno;
+ char   *sgParseRedirect       __P((char *, struct SquidInfo *, struct Acl *, struct AclDest *));
+ char   *sgAclAccess __P((struct Source *, struct Acl *, struct SquidInfo *));
+--- a/src/main.c.in    2020-03-08 20:10:55.650000000 +0300
++++ b/src/main.c.in    2020-03-08 20:11:13.590000000 +0300
+@@ -21,6 +21,9 @@
+ #include <syslog.h>
+ #endif
++char *progname;
++int lineno;
++
+ struct Setting *lastSetting = NULL;
+ struct Setting *Setting = NULL;                        /* linked list, Calloc */
+--- a/src/sg.y.in      2020-03-08 20:14:46.180000000 +0300
++++ b/src/sg.y.in      2020-03-08 20:14:57.110000000 +0300
+@@ -35,7 +35,7 @@
+ #include "sgEx.h"
+-FILE *yyin, *yyout;
++extern FILE *yyin, *yyout;
+ char *configFile;
+ int numTimeElements;
index 066fb4c60481f5f9e039352c191b00fb60765afa..2b3d62ad4af9277114c47c7d7f844f444e6b7244 100644 (file)
@@ -41,7 +41,8 @@ suitable_db_version() {
 
 src_prepare() {
        eapply \
-               "${FILESDIR}/${P}-gentoo.patch"
+               "${FILESDIR}/${P}-gentoo.patch" \
+               "${FILESDIR}/${P}-gcc-10.patch"
 
        # Link only with specific BerkDB versions
        db_version="$(suitable_db_version)"