app-editors/curses-hexedit: Fix building with CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Sun, 17 May 2020 12:50:25 +0000 (14:50 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 17 May 2020 12:51:12 +0000 (14:51 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Closes: https://bugs.gentoo.org/706996
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
app-editors/curses-hexedit/curses-hexedit-0.9.7-r1.ebuild [new file with mode: 0644]
app-editors/curses-hexedit/files/curses-hexedit-0.9.7-fno-common.patch [new file with mode: 0644]

diff --git a/app-editors/curses-hexedit/curses-hexedit-0.9.7-r1.ebuild b/app-editors/curses-hexedit/curses-hexedit-0.9.7-r1.ebuild
new file mode 100644 (file)
index 0000000..f274d12
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# There's already a "hexedit" package in the tree, so name this one differently
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+MY_P=${P/curses-}
+DESCRIPTION="full screen curses hex editor (with insert/delete support)"
+HOMEPAGE="http://www.rogoyski.com/adam/programs/hexedit/"
+SRC_URI="http://www.rogoyski.com/adam/programs/hexedit/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       sys-libs/ncurses:=
+"
+DEPEND="
+       ${RDEPEND}
+"
+PATCHES=(
+       "${FILESDIR}"/${P}-fno-common.patch
+       "${FILESDIR}"/${P}-ncurses-pkg-config.patch
+)
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf --program-prefix=curses-
+}
diff --git a/app-editors/curses-hexedit/files/curses-hexedit-0.9.7-fno-common.patch b/app-editors/curses-hexedit/files/curses-hexedit-0.9.7-fno-common.patch
new file mode 100644 (file)
index 0000000..c4fe48b
--- /dev/null
@@ -0,0 +1,53 @@
+--- a/src/hexedit.h
++++ b/src/hexedit.h
+@@ -340,7 +340,7 @@
+    /* Global structure, keep most global variables here. */
+-struct
++struct Globals_t
+ {
+    WINDOW *wmain, *wstatus, *whelp; /* three windows used throughout. */
+    unsigned long filesize;          /* size of the file buffer. */
+@@ -362,7 +362,9 @@
+                                     /* buf end. */
+    int beeping;                     /* Allow beeping or not. */
+    int help_msg_count;              /* Number of messages in help menu. */
+-} Globals;
++};
++
++extern struct Globals_t Globals;
+ struct foundit
+@@ -397,7 +399,9 @@
+    int s;
+    struct Change *base;
+    struct Change *top;
+-} UndoStack;
++};
++
++extern struct ChangeLog UndoStack;
+ struct FileNames
+--- a/src/main.c
++++ b/src/main.c
+@@ -16,6 +16,7 @@
+ #include "hexedit.h"
+ #include <assert.h>
++struct Globals_t Globals;
+ int
+ main (int argc, char **argv)
+--- a/src/undo.c
++++ b/src/undo.c
+@@ -15,6 +15,7 @@
+ #include <assert.h>
+ #include "hexedit.h"
++struct ChangeLog UndoStack;
+ void
+ pushUndo (int type, unsigned long offset,