media-libs/alsa-lib: Bump to version 1.2.2
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 20 Feb 2020 15:18:31 +0000 (16:18 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 20 Feb 2020 15:49:28 +0000 (16:49 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
media-libs/alsa-lib/Manifest
media-libs/alsa-lib/alsa-lib-1.2.2.ebuild [new file with mode: 0644]

index 227a283af80ed45b35f522b3e649c34a442751cc..0fab83a64ee80ca580c7c03d286a4dbbf9e8f083 100644 (file)
@@ -3,3 +3,4 @@ DIST alsa-lib-1.1.8.tar.bz2 1002562 BLAKE2B a531ab501943924d007f7ae0e4489deea805
 DIST alsa-lib-1.1.9.tar.bz2 1058187 BLAKE2B 60454be162a0f36334602586762f8ce657d2883636bcb65ae91dedce62297bd40f3dbdc6213ef773542708b367f8796e143b1fc987c40de6d5d5a69a648f6b18 SHA512 402e39cca82d17555e3e52ef06b8ed9dcf58531da393809a7b5cf18658299fa90ee8a60bfc5213482d7a02b13140c441f1333b144556f44ab4adb786a2fb3c49
 DIST alsa-lib-1.2.1.1.tar.bz2 1002960 BLAKE2B 6df2145e0fdd42b86759a6250f6fa3d18075d1bbff1c5ec0b4b6130f934ab369e5cc0edd9a53c3b6298dce0d374a9888c5fc63ae0d42b3fd0ef5ca97eff00369 SHA512 8a0b6f1ecc58d60991b4509e791b1581eebae57cd754b0b4829e66b1cfee81d588b04f42a17f598f06310b9658d9f46fd748cca516cc48b6f2989389c22c42e9
 DIST alsa-lib-1.2.1.2.tar.bz2 1004129 BLAKE2B e8bf117f3036a32b020897f16b9648ac105c499f547ae157508720502722d4e1a651719c86a4e2756ca7a3c573a1f17c02524125ccaad12bcb8c7c71675c898a SHA512 e8286fd55f63ee0d95513279d0885c287533de89b7af6c338413dec5d38ba4f5a15da1a4a4ce36e052614e4b730e3778782dab9979d82958283be17b48604913
+DIST alsa-lib-1.2.2.tar.bz2 1030747 BLAKE2B 176054c7783452fcd0b30482f4d85fb88a1364a97f79830f2c22cd578275280fa64537d00a08f3e3b1420e4aeb4e4269c7523cb4296db3ed095bcf078b452726 SHA512 d21adb3ff998918c7d1820f9ce2aaf4202dd45ccb87cb092d49da8b2402b6ddaad06325be0fd59f17393a5d9958e3743bfccb4b14bdb947a42e7d791d73c7033
diff --git a/media-libs/alsa-lib/alsa-lib-1.2.2.ebuild b/media-libs/alsa-lib/alsa-lib-1.2.2.ebuild
new file mode 100644 (file)
index 0000000..c09b03a
--- /dev/null
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+
+inherit autotools multilib multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="https://alsa-project.org/"
+SRC_URI="https://www.alsa-project.org/files/pub/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc elibc_uclibc python +thread-safety"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+       doc? ( >=app-doc/doxygen-1.2.6 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.1.6-missing_files.patch" #652422
+)
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+       # https://bugs.gentoo.org/509886
+       if use elibc_uclibc ; then
+               sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die
+       fi
+       # https://bugs.gentoo.org/545950
+       sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
+       default
+       eautoreconf
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               --disable-maintainer-mode
+               --disable-resmgr
+               --enable-aload
+               --enable-rawmidi
+               --enable-seq
+               --enable-shared
+               # enable Python only on final ABI
+               $(multilib_native_use_enable python)
+               $(use_enable alisp)
+               $(use_enable thread-safety)
+               $(use_with debug)
+               $(usex elibc_uclibc --without-versioned '')
+       )
+
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+       emake
+
+       if multilib_is_native_abi && use doc; then
+               emake doc
+               grep -FZrl "${S}" doc/doxygen/html | \
+                       xargs -0 sed -i -e "s:${S}::"
+       fi
+}
+
+multilib_src_install() {
+       emake DESTDIR="${D}" install
+       if multilib_is_native_abi && use doc; then
+               docinto html
+               dodoc -r doc/doxygen/html/.
+       fi
+}
+
+multilib_src_install_all() {
+       find "${ED}" -type f \( -name '*.a' -o -name '*.la' \) -delete || die
+       dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}