Remove old version
authorTristan Heaven <tristan@gentoo.org>
Thu, 23 Nov 2006 23:58:52 +0000 (23:58 +0000)
committerTristan Heaven <tristan@gentoo.org>
Thu, 23 Nov 2006 23:58:52 +0000 (23:58 +0000)
Package-Manager: portage-2.1.2_rc2-r1

games-mud/ytin/files/digest-ytin-1.83.5-r1
games-mud/ytin/ytin-1.83.5-r1.ebuild

index 345e349ecefdf7299a447cc77defcc838bff11b7..ce300a6752569f9fdd463512f916f4b0ad86da04 100644 (file)
@@ -1 +1,3 @@
 MD5 5df92a6627963dfbb816978b15a50888 ytin.tar.gz 282724
+RMD160 9d489950522c1aacb3a399690f1aa58408275486 ytin.tar.gz 282724
+SHA256 4ad53f1b8be85ff1a11ab21fe1d02d5a863b313a51295c655410ed183a515cbc ytin.tar.gz 282724
index ec3ee7e575b1eb24105a04863f511ff40708c317..3defc19ba4ddaf0c3514a9b2f611f8b50268d108 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/ytin/ytin-1.83.5-r1.ebuild,v 1.6 2004/12/21 12:26:17 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/ytin/ytin-1.83.5-r1.ebuild,v 1.7 2006/11/23 23:58:52 nyhm Exp $
 
-inherit games
+inherit toolchain-funcs games
 
 DESCRIPTION="yet another TinTin++"
 HOMEPAGE="http://ytin.sourceforge.net/"
@@ -10,19 +10,14 @@ SRC_URI="mirror://sourceforge/ytin/${PN}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc x86"
 IUSE=""
 
-RDEPEND="virtual/libc
-       sys-libs/ncurses"
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
-
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
 
 src_unpack() {
        unpack ${A}
-       cd ${S}
+       cd "${S}"
        sed -i \
                -e 's:extern int errno;::' utils.cpp \
                        || die "sed utils.cpp failed"
@@ -33,12 +28,15 @@ src_unpack() {
 }
 
 src_compile() {
-       econf || die
-       emake CFLAGS="${CFLAGS}" || die "emake died"
+       egamesconf || die
+       emake \
+               CC="$(tc-getCC)" \
+               CFLAGS="${CFLAGS}" \
+               || die "emake failed"
 }
 
 src_install() {
-       dogamesbin tt++ || die
+       dogamesbin tt++ || die "dogamesbin failed"
        dodoc ChangeLog README.1st docs/*.txt
        prepgamesdirs
 }