app-emulation/open-vm-tools: append tirpc flags to CPPFLAGS instead of CFLAGS
authorMike Gilbert <floppym@gentoo.org>
Thu, 30 Nov 2017 16:35:16 +0000 (11:35 -0500)
committerMike Gilbert <floppym@gentoo.org>
Thu, 30 Nov 2017 16:35:36 +0000 (11:35 -0500)
Fixes a build failure with gtkmm enabled.

Closes: https://bugs.gentoo.org/639266
Package-Manager: Portage-2.3.15, Repoman-2.3.6_p7

app-emulation/open-vm-tools/open-vm-tools-10.1.15.ebuild

index 720431f89aa3230d7da54cc5f81fc5bf31b9dd4c..3829a224743b809d645c94d86521c7d2ceb0a12d 100644 (file)
@@ -83,7 +83,7 @@ src_prepare() {
 }
 
 src_configure() {
-       append-cflags "$($(tc-getPKG_CONFIG) --cflags libtirpc)"
+       append-cppflags "$($(tc-getPKG_CONFIG) --cflags libtirpc)"
        export LIBVMTOOLS_LIBADD="$($(tc-getPKG_CONFIG) --libs libtirpc)"
        local myeconfargs=(
                --disable-deploypkg