app-crypt/scute: eapi bump
authorAlon Bar-Lev <alonbl@gentoo.org>
Sun, 23 Sep 2018 13:30:59 +0000 (16:30 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Thu, 27 Sep 2018 23:51:37 +0000 (02:51 +0300)
Package-Manager: Portage-2.3.49, Repoman-2.3.10

app-crypt/scute/scute-1.5.0.ebuild

index 85adede2192a62217706ac633c692a42672ba34b..9403b7ae96441bc2f7ed9b2f52c2e7e675123279 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-
-inherit ltprune
+EAPI=7
 
 DESCRIPTION="A PKCS #11 module for OpenPGP smartcards"
 HOMEPAGE="http://www.scute.org/"
@@ -12,18 +10,17 @@ SRC_URI="mirror://gnupg/scute/${P}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64"
-IUSE=""
 
 # configure script try to check the version of gpgsm and gpg-agent when
 # non-crosscompiling so we need to have them as build-time dependency as
 # well as runtime.  Require a version of gnupg that is patched to have
 # gpgsm-gencert.sh working (as that's what the documentation describe).
-DEPEND="
-       >=dev-libs/libgpg-error-1.4
-       >=dev-libs/libassuan-2.0.0
-       >=app-crypt/pinentry-0.7.0
+BDEPEND=">=app-crypt/pinentry-0.7.0
        >=app-crypt/gnupg-2.0.17-r1[smartcard]"
-RDEPEND="${DEPEND}"
+DEPEND=">=dev-libs/libgpg-error-1.4
+       >=dev-libs/libassuan-2.0.0"
+RDEPEND="${DEPEND}
+       ${BDEPEND}"
 
 src_configure() {
        econf \
@@ -33,5 +30,5 @@ src_configure() {
 
 src_install() {
        default
-       prune_libtool_files --modules
+       find "${D}" -name '*.la' -delete || die
 }