projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2e85bfd
)
dev-python/twisted: Run tests in virtx to avoid crashing
author
Michał Górny
<mgorny@gentoo.org>
Fri, 24 Apr 2020 08:16:09 +0000
(10:16 +0200)
committer
Michał Górny
<mgorny@gentoo.org>
Fri, 24 Apr 2020 08:18:57 +0000
(10:18 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/twisted/twisted-19.10.0.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/twisted/twisted-19.10.0.ebuild
b/dev-python/twisted/twisted-19.10.0.ebuild
index 7dc1cb2ddc545f9ac5607f1adf1051de81ac2cda..1fedad603686e9bbb076d9855352948cfa26765a 100644
(file)
--- a/
dev-python/twisted/twisted-19.10.0.ebuild
+++ b/
dev-python/twisted/twisted-19.10.0.ebuild
@@
-6,7
+6,7
@@
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
+inherit distutils-r1
virtualx
TWISTED_PN="Twisted"
TWISTED_P="${TWISTED_PN}-${PV}"
@@
-98,6
+98,10
@@
python_prepare_all() {
distutils-r1_python_prepare_all
}
+src_test() {
+ virtx distutils-r1_src_test
+}
+
python_test() {
distutils_install_for_testing