dev-python/expects: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 08:44:02 +0000 (09:44 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 08:57:56 +0000 (09:57 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/expects/expects-0.8.0.ebuild [deleted file]

diff --git a/dev-python/expects/expects-0.8.0.ebuild b/dev-python/expects/expects-0.8.0.ebuild
deleted file mode 100644 (file)
index 28a0c94..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
-HOMEPAGE="https://github.com/jaimegildesagredo/expects"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/mamba[${PYTHON_USEDEP}] )
-"
-RDEPEND=""
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       mamba || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-
-       distutils-r1_python_install_all
-}