media-video/flvstreamer: EAPI-7 bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 18 Aug 2018 08:17:12 +0000 (10:17 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 18 Aug 2018 08:17:12 +0000 (10:17 +0200)
Thanks-to: Michael Mair-Keimberger (iamnr3) <bu9zilla@gmail.com>
Closes: https://bugs.gentoo.org/663804
Closes: https://github.com/gentoo/gentoo/pull/9198

media-video/flvstreamer/flvstreamer-2.1c.ebuild

index f8aed0990fb4262fe46789e82420eca388438c2f..2989c8af30d74661f36202d78be00c642a89f38e 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="2"
+EAPI=7
 
 inherit toolchain-funcs
 
@@ -13,12 +13,13 @@ LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~ppc x86"
 IUSE=""
+
 S="${WORKDIR}/${PN}"
 
 src_prepare() {
+       default
        #fix Makefile ( bug #298535 and bug #318353)
-       sed -i 's/\$(MAKEFLAGS)//g' Makefile \
-               || die "failed to fixe Makefile"
+       sed -i 's/\$(MAKEFLAGS)//g' Makefile || die "failed to fix Makefile"
 }
 
 src_compile() {
@@ -30,6 +31,6 @@ src_compile() {
 }
 
 src_install() {
-       dobin {${PN},streams} || die "dobin failed"
-       dodoc README ChangeLog || die "dodoc failed"
+       dobin {${PN},streams}
+       dodoc README ChangeLog
 }