Revert "app-crypt/gpgme: cleanup"
authorAlon Bar-Lev <alonbl@gentoo.org>
Fri, 17 Mar 2017 09:37:49 +0000 (11:37 +0200)
committerAlon Bar-Lev <alonbl@gentoo.org>
Fri, 17 Mar 2017 09:40:43 +0000 (11:40 +0200)
This reverts commit 75af8f68a0e80c3c7f5062aa8eed9ea117383052.

app-crypt/gpgme/Manifest
app-crypt/gpgme/gpgme-1.5.5.ebuild [new file with mode: 0644]

index 26a86d808500d1f0af6882ca0d9ccee88bd3071c..6c034065a5debd4e34e9dd7f2c05acb2554dd1cd 100644 (file)
@@ -1,2 +1,3 @@
+DIST gpgme-1.5.5.tar.bz2 976383 SHA256 0b3d3d5107680c594777aae65882a1ff6dd1ba629a83432e719c8b82a743c207 SHA512 a01b84c1ae2a7c647b2de793fc05d39c4bf4a2d1b7378934e437857823f11ca9e9c1f3b32302d69a3a84d0be1fee1e1c86874355031b8fa6b40f4ad56ecc72ad WHIRLPOOL f3ad4282a254cf1ab8d01184df787a773fa7963a42157da93bee11430263fa86166f12f051e2b11d13be99ce1f0939d565cb02a8fba93ab6afed73ca7b2c0041
 DIST gpgme-1.6.0.tar.bz2 983573 SHA256 b09de4197ac280b102080e09eaec6211d081efff1963bf7821cf8f4f9916099d SHA512 b7ccccc2bac246b0759c8752cadd3e77f03da39711badfc66d0f21cefab3f3b07fe1038611ad9ca1c16a8a48d7e831dcca68d83d052456a4cf794a73e287d41b WHIRLPOOL 4e753156474097dba9db2905954d1754ca408066996a01cbc7266a24654eb7c2323043f40495cc3c227d8eef540eeca47de4c23bb329a2d34604d5a4d3828970
 DIST gpgme-1.8.0.tar.bz2 1298407 SHA256 596097257c2ce22e747741f8ff3d7e24f6e26231fa198a41b2a072e62d1e5d33 SHA512 9f214a44ddc4d602c2a0befc66aa6be9f2c90a24e153b873475867e30eec30e074826b98c11d20b0a2e4cd04e2625ce2545220481225fceb6ca9c51d3208e3de WHIRLPOOL 79ed725e24302d4d738e90739cf3c5e6e9fa89c3e4fef87a4fca569abb7f7b7f0140e62e76161f747b555f49166fd0ccda277dbd6cc46c00ce2797c32d442f7b
diff --git a/app-crypt/gpgme/gpgme-1.5.5.ebuild b/app-crypt/gpgme/gpgme-1.5.5.ebuild
new file mode 100644 (file)
index 0000000..d95c076
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils libtool
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1/11" # subslot = soname major version
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="common-lisp static-libs"
+
+DEPEND="app-crypt/gnupg
+       >=dev-libs/libassuan-2.0.2
+       >=dev-libs/libgpg-error-1.11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-1.1.8-et_EE.patch
+       elibtoolize
+}
+
+src_configure() {
+       econf \
+               --includedir="${EPREFIX}/usr/include/gpgme" \
+               $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       prune_libtool_files
+
+       if ! use common-lisp; then
+               rm -fr "${ED}usr/share/common-lisp"
+       fi
+}