Version bump, make twisted dependency stricter.
authorMarien Zwart <marienz@gentoo.org>
Thu, 11 Jan 2007 22:20:21 +0000 (22:20 +0000)
committerMarien Zwart <marienz@gentoo.org>
Thu, 11 Jan 2007 22:20:21 +0000 (22:20 +0000)
Package-Manager: portage-2.1.2_rc4-r8

22 files changed:
dev-python/twisted-lore/ChangeLog
dev-python/twisted-lore/files/digest-twisted-lore-0.3.0 [new file with mode: 0644]
dev-python/twisted-lore/twisted-lore-0.2.0.ebuild
dev-python/twisted-lore/twisted-lore-0.3.0.ebuild [new file with mode: 0644]
dev-python/twisted-mail/ChangeLog
dev-python/twisted-mail/files/digest-twisted-mail-0.1.0-r1
dev-python/twisted-mail/files/digest-twisted-mail-0.4.0 [new file with mode: 0644]
dev-python/twisted-mail/twisted-mail-0.3.0.ebuild
dev-python/twisted-mail/twisted-mail-0.4.0.ebuild [new file with mode: 0644]
dev-python/twisted-names/ChangeLog
dev-python/twisted-names/files/digest-twisted-names-0.4.0 [new file with mode: 0644]
dev-python/twisted-names/twisted-names-0.3.0.ebuild
dev-python/twisted-names/twisted-names-0.4.0.ebuild [new file with mode: 0644]
dev-python/twisted-news/ChangeLog
dev-python/twisted-news/files/digest-twisted-news-0.3.0 [new file with mode: 0644]
dev-python/twisted-news/twisted-news-0.2.0.ebuild
dev-python/twisted-news/twisted-news-0.3.0.ebuild [new file with mode: 0644]
dev-python/twisted-words/ChangeLog
dev-python/twisted-words/files/digest-twisted-words-0.5.0 [new file with mode: 0644]
dev-python/twisted-words/twisted-words-0.4.0-r1.ebuild
dev-python/twisted-words/twisted-words-0.4.0.ebuild
dev-python/twisted-words/twisted-words-0.5.0.ebuild [new file with mode: 0644]

index 79491b39b80a03c07ec5176cb4d4e5d7138776a8..90c0a84cb8199c13bfc26a0385d65afa0951b72c 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/twisted-lore
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.17 2006/10/21 02:05:56 agriffis Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.18 2007/01/11 22:14:01 marienz Exp $
+
+*twisted-lore-0.3.0 (11 Jan 2007)
+
+  11 Jan 2007; Marien Zwart <marienz@gentoo.org> twisted-lore-0.2.0.ebuild,
+  +twisted-lore-0.3.0.ebuild:
+  Version bump, make twisted dependency stricter.
 
   21 Oct 2006; Aron Griffis <agriffis@gentoo.org> twisted-lore-0.2.0.ebuild:
   Mark 0.2.0 stable on ia64
diff --git a/dev-python/twisted-lore/files/digest-twisted-lore-0.3.0 b/dev-python/twisted-lore/files/digest-twisted-lore-0.3.0
new file mode 100644 (file)
index 0000000..7c5765e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 3e1476bf25f420bcd76351a22630e7c3 TwistedLore-0.3.0.tar.bz2 64407
+RMD160 373e88c9e82eb2ae9a0f2521c21b8dfe729aa644 TwistedLore-0.3.0.tar.bz2 64407
+SHA256 c7d3f1c1154a4773052ec6f3e62794f0dc6ca90d86f98a2b2c3c3c45f4f8eab0 TwistedLore-0.3.0.tar.bz2 64407
index 07b90c3fcfbd8bc87baba3a40752e6c5ca57f6ba..8555c89a59ce5aaa6eab1fd498df808c2bfa16e9 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-0.2.0.ebuild,v 1.5 2006/10/21 02:05:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-0.2.0.ebuild,v 1.6 2007/01/11 22:14:01 marienz Exp $
 
 MY_PACKAGE=Lore
 
@@ -10,5 +10,5 @@ DESCRIPTION="Twisted documentation system"
 
 KEYWORDS="alpha amd64 ia64 ~ppc ~sparc ~x86"
 
-DEPEND=">=dev-python/twisted-2.4
+DEPEND="=dev-python/twisted-2.4*
        dev-python/twisted-web"
diff --git a/dev-python/twisted-lore/twisted-lore-0.3.0.ebuild b/dev-python/twisted-lore/twisted-lore-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..b47dd24
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-0.3.0.ebuild,v 1.1 2007/01/11 22:14:01 marienz Exp $
+
+MY_PACKAGE=Lore
+
+inherit twisted
+
+DESCRIPTION="Twisted documentation system"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="=dev-python/twisted-2.5*
+       dev-python/twisted-web"
index 75aebf190d2dd3ecd13927a82c126d75d736568e..04cebbe2be19e2066021c3fde92e34e608befa9a 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/twisted-mail
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/ChangeLog,v 1.19 2006/10/20 20:38:17 kloeri Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/ChangeLog,v 1.20 2007/01/11 22:18:24 marienz Exp $
+
+*twisted-mail-0.4.0 (11 Jan 2007)
+
+  11 Jan 2007; Marien Zwart <marienz@gentoo.org> twisted-mail-0.3.0.ebuild,
+  +twisted-mail-0.4.0.ebuild:
+  Version bump, make twisted dependency stricter.
 
   20 Oct 2006; Bryan Ã˜stergaard <kloeri@gentoo.org>
   twisted-mail-0.3.0.ebuild:
index f2d193e6533ee591fe690a3fd9d57ab276402122..26630fdee8e73e5558e9b670e120a5d63f5e0ec0 100644 (file)
@@ -1 +1,3 @@
 MD5 020c622156b4e754ca0bab66cff0720b TwistedMail-0.1.0.tar.bz2 97342
+RMD160 d570274a6d617b198e5fe703a3e4a33c6f9fae03 TwistedMail-0.1.0.tar.bz2 97342
+SHA256 d73060005e94d6e432b1e04d092da808c78f286c318306d3df9d2ffdaa0dc9c0 TwistedMail-0.1.0.tar.bz2 97342
diff --git a/dev-python/twisted-mail/files/digest-twisted-mail-0.4.0 b/dev-python/twisted-mail/files/digest-twisted-mail-0.4.0
new file mode 100644 (file)
index 0000000..3bf9efa
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b2e1428b527333878434777f284f0e91 TwistedMail-0.4.0.tar.bz2 121483
+RMD160 3de8e137f8c979200c98821a50f85b28b880688e TwistedMail-0.4.0.tar.bz2 121483
+SHA256 92e67552e4c4684972377d981d19cb33173998545a5276def8882fe2c15ac094 TwistedMail-0.4.0.tar.bz2 121483
index 290bd4457ef0a5762c79dc7b1b66fbecd09e08a0..21cf7e55063fb88ce7db511b80269d94ec979f11 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/twisted-mail-0.3.0.ebuild,v 1.5 2006/10/20 20:38:17 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/twisted-mail-0.3.0.ebuild,v 1.6 2007/01/11 22:18:24 marienz Exp $
 
 MY_PACKAGE=Mail
 
@@ -10,5 +10,5 @@ DESCRIPTION="A Twisted Mail library, server and client."
 
 KEYWORDS="alpha amd64 ia64 ~ppc ~sparc ~x86"
 
-DEPEND=">=dev-python/twisted-2.4
+DEPEND="=dev-python/twisted-2.4*
        >=dev-python/twisted-names-0.2.0"
diff --git a/dev-python/twisted-mail/twisted-mail-0.4.0.ebuild b/dev-python/twisted-mail/twisted-mail-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..757d668
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/twisted-mail-0.4.0.ebuild,v 1.1 2007/01/11 22:18:24 marienz Exp $
+
+MY_PACKAGE=Mail
+
+inherit twisted
+
+DESCRIPTION="A Twisted Mail library, server and client."
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="=dev-python/twisted-2.5*
+       >=dev-python/twisted-names-0.2.0"
index 2155b4dce1a537ad86ae37fa050b26438a7befe9..02f0806dfc2c8d10c010b7e182574fecfe11c628 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/twisted-names
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.16 2006/10/20 20:38:15 kloeri Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.17 2007/01/11 22:19:10 marienz Exp $
+
+*twisted-names-0.4.0 (11 Jan 2007)
+
+  11 Jan 2007; Marien Zwart <marienz@gentoo.org> twisted-names-0.3.0.ebuild,
+  +twisted-names-0.4.0.ebuild:
+  Version bump, make twisted dependency stricter.
 
   20 Oct 2006; Bryan Ã˜stergaard <kloeri@gentoo.org>
   twisted-names-0.3.0.ebuild:
diff --git a/dev-python/twisted-names/files/digest-twisted-names-0.4.0 b/dev-python/twisted-names/files/digest-twisted-names-0.4.0
new file mode 100644 (file)
index 0000000..7ab14a0
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 fae00c3c1489b6818d16b84f8ffcc807 TwistedNames-0.4.0.tar.bz2 32692
+RMD160 70b819f65ca20175d04ab355ec05ddc1100e357a TwistedNames-0.4.0.tar.bz2 32692
+SHA256 3e438da6f4d43fb74249f38746e0b38a26d2f90cb0ac6b24519eb44b3503737d TwistedNames-0.4.0.tar.bz2 32692
index 03542f620be13d57aacc2a4c70a26047644398a5..99968af04195aa9d63637fa925440a3c5a1d6b7f 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-0.3.0.ebuild,v 1.4 2006/10/20 20:38:15 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-0.3.0.ebuild,v 1.5 2007/01/11 22:19:10 marienz Exp $
 
 MY_PACKAGE=Names
 
@@ -10,4 +10,4 @@ DESCRIPTION="A Twisted DNS implementation."
 
 KEYWORDS="alpha amd64 ia64 ~ppc ~sparc ~x86"
 
-DEPEND=">=dev-python/twisted-2.4"
+DEPEND="=dev-python/twisted-2.4*"
diff --git a/dev-python/twisted-names/twisted-names-0.4.0.ebuild b/dev-python/twisted-names/twisted-names-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..38aefd6
--- /dev/null
@@ -0,0 +1,13 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-0.4.0.ebuild,v 1.1 2007/01/11 22:19:10 marienz Exp $
+
+MY_PACKAGE=Names
+
+inherit twisted
+
+DESCRIPTION="A Twisted DNS implementation."
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="=dev-python/twisted-2.5*"
index 0e5657ced19da719bdec21ebce78ea2557d9588c..b78e2bf35d8e1cbf698d95526f8d0b6f773bb2e8 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/twisted-news
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.16 2007/01/03 02:37:39 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.17 2007/01/11 22:19:46 marienz Exp $
+
+*twisted-news-0.3.0 (11 Jan 2007)
+
+  11 Jan 2007; Marien Zwart <marienz@gentoo.org> twisted-news-0.2.0.ebuild,
+  +twisted-news-0.3.0.ebuild:
+  Version bump, make twisted dependency stricter.
 
   03 Jan 2007; Steve Dibb <beandog@gentoo.org> twisted-news-0.2.0.ebuild:
   amd64 stable, bug 128688
diff --git a/dev-python/twisted-news/files/digest-twisted-news-0.3.0 b/dev-python/twisted-news/files/digest-twisted-news-0.3.0
new file mode 100644 (file)
index 0000000..1c5765d
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 cacbebf47882e57ca04d5c2ec3601830 TwistedNews-0.3.0.tar.bz2 16918
+RMD160 51f2f608f0c0564f645f54daf962ae2021d50f86 TwistedNews-0.3.0.tar.bz2 16918
+SHA256 92497826210557388f87bb20105fb234359c60bb006db1dcd074877ad3cccd16 TwistedNews-0.3.0.tar.bz2 16918
index 34fd5aa9775ff3940fb398b5c22767a252935034..a5da66c5c7a95cbc28ef44260953882c211e549c 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-0.2.0.ebuild,v 1.6 2007/01/03 02:37:39 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-0.2.0.ebuild,v 1.7 2007/01/11 22:19:46 marienz Exp $
 
 MY_PACKAGE=News
 
@@ -10,5 +10,5 @@ DESCRIPTION="Twisted News is an NNTP server and programming library."
 
 KEYWORDS="alpha amd64 ia64 ~ppc ~sparc ~x86"
 
-DEPEND=">=dev-python/twisted-2.4
+DEPEND="=dev-python/twisted-2.4*
        dev-python/twisted-mail"
diff --git a/dev-python/twisted-news/twisted-news-0.3.0.ebuild b/dev-python/twisted-news/twisted-news-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..d344f16
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-0.3.0.ebuild,v 1.1 2007/01/11 22:19:46 marienz Exp $
+
+MY_PACKAGE=News
+
+inherit twisted
+
+DESCRIPTION="Twisted News is an NNTP server and programming library."
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="=dev-python/twisted-2.5*
+       dev-python/twisted-mail"
index 77565b9fd1695fa13a4faa852447a608b7fe8dfd..f118be2f9c57085179bee005d9396894abb15864 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/twisted-words
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/ChangeLog,v 1.20 2006/11/18 22:44:07 compnerd Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/ChangeLog,v 1.21 2007/01/11 22:20:21 marienz Exp $
+
+*twisted-words-0.5.0 (11 Jan 2007)
+
+  11 Jan 2007; Marien Zwart <marienz@gentoo.org> twisted-words-0.4.0.ebuild,
+  twisted-words-0.4.0-r1.ebuild, +twisted-words-0.5.0.ebuild:
+  Version bump, make twisted dependency stricter.
 
   18 Nov 2006; Saleem Abdulrasool <compnerd@gentoo.org>
   twisted-words-0.1.0-r2.ebuild, twisted-words-0.3.0-r1.ebuild,
diff --git a/dev-python/twisted-words/files/digest-twisted-words-0.5.0 b/dev-python/twisted-words/files/digest-twisted-words-0.5.0
new file mode 100644 (file)
index 0000000..c38bf15
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 7004f93a2358abe093bed55c2fff25ef TwistedWords-0.5.0.tar.bz2 151747
+RMD160 3099268bad257791e5b259d7ad182bd51cc3d7c0 TwistedWords-0.5.0.tar.bz2 151747
+SHA256 30974a82128e31ae1223f0962fcabf4aad45465d34068f51acb0144e759b002f TwistedWords-0.5.0.tar.bz2 151747
index a309c53c9c0d3a48379d01017f093842ce58f249..b02ebd66119c9f657c85b87c5aea7a9a8d48b40a 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-0.4.0-r1.ebuild,v 1.6 2006/11/18 22:44:07 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-0.4.0-r1.ebuild,v 1.7 2007/01/11 22:20:21 marienz Exp $
 
 MY_PACKAGE=Words
 
@@ -10,7 +10,7 @@ DESCRIPTION="Twisted Words contains Instant Messaging implementations."
 
 KEYWORDS="alpha amd64 ia64 ~ppc ~sparc ~x86"
 
-DEPEND=">=dev-python/twisted-2.4
+DEPEND="=dev-python/twisted-2.4*
        dev-python/twisted-web"
 
 IUSE=""
index 75a8a5e3da9b7140ec454a609dd315ce3ac8d8f2..4310a1271798c7645a063be4fa6beee3499b84ac 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-0.4.0.ebuild,v 1.1 2006/05/26 18:47:48 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-0.4.0.ebuild,v 1.2 2007/01/11 22:20:21 marienz Exp $
 
 MY_PACKAGE=Words
 
@@ -10,5 +10,5 @@ DESCRIPTION="Twisted Words contains Instant Messaging implementations."
 
 KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
 
-DEPEND=">=dev-python/twisted-2.4
+DEPEND="=dev-python/twisted-2.4*
        dev-python/twisted-web"
diff --git a/dev-python/twisted-words/twisted-words-0.5.0.ebuild b/dev-python/twisted-words/twisted-words-0.5.0.ebuild
new file mode 100644 (file)
index 0000000..c63ad20
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-0.5.0.ebuild,v 1.1 2007/01/11 22:20:21 marienz Exp $
+
+MY_PACKAGE=Words
+
+inherit twisted
+
+DESCRIPTION="Twisted Words contains Instant Messaging implementations."
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="=dev-python/twisted-2.5*
+       dev-python/twisted-web"
+
+IUSE=""
+
+
+src_install() {
+       twisted_src_install
+
+       # Remove the "im" script we do not depend on the required pygtk.
+       rm -rf "${D}"/usr/{bin,share/man}
+}