dev-libs/intel-neo: bump to 19.48.14977
authorMarek Szuba <marecki@gentoo.org>
Tue, 10 Dec 2019 12:47:50 +0000 (12:47 +0000)
committerMarek Szuba <marecki@gentoo.org>
Tue, 10 Dec 2019 12:49:41 +0000 (12:49 +0000)
No major changes since 19.46 but Ice Lake support is now
officially production-level again (for the record: according to upstream
the failures in 19.46 and 19.47 were caused by time-outs due to
increased test run time after 64-bit atomics had been enabled for ICL,
thus making an increase of the threshold value the only change required
to address this issue).

Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-libs/intel-neo/Manifest
dev-libs/intel-neo/intel-neo-19.48.14977.ebuild [new file with mode: 0644]

index 9e670cc9cc5c94cb049c764e453e0e9255d80432..31f34a64f52917b0834a74771b6a70a5fb73168a 100644 (file)
@@ -2,3 +2,4 @@ DIST intel-neo-19.22.13062.tar.gz 2402939 BLAKE2B e47f19fa602444cb260a2cdd9b6762
 DIST intel-neo-19.30.13641.tar.gz 2446018 BLAKE2B 640b3076c928eab80911d219dabda85029f544d62ff7d39de465f89844f244e75afe053f8475db79aba88a969252d3d5141f0167c8bc7f05120a71fd9ccfda26 SHA512 70aaccc74d74c1ecc9098e579fd6ad154b22eb6024f84aab626d92ece33f5d5d75bdded1656fa7250f34b5b69f69767f39e22b9777601152a5ae6b32d8e1c796
 DIST intel-neo-19.38.14237.tar.gz 2480609 BLAKE2B d44b00038009d6fc549f7cb17f248f83b6848d152cbb0a0815a5537b4e6131e5087ec231d777eb425b13aee27954c4526ede4859305e5312ad34cc7ec32b0897 SHA512 5886c1565405410da27fd3f2f38e78e9d7017968ec92a2819206e53eeeace3903c3d14fae9b5a5abf582cece5fe1d54bc1db18301846c668af768fcac5854c91
 DIST intel-neo-19.46.14807.tar.gz 2582591 BLAKE2B 07f65bf191e81a863e840a85c89d7632edfde814da0a00beaac0124293bf44a4d7bc45abdb0d8444dafcdaba24f83194d37df55297e0d0b32c91f622498e75c4 SHA512 fdf37bd51ffbf286d00ec395ba7f6bd53e0555610ed88ef201f2baaf1a03fb73137d0cd502119aba4cb6e146d2cd03c08bd20e004e6be3381104af9e24381820
+DIST intel-neo-19.48.14977.tar.gz 2633172 BLAKE2B 296c85c89833e49f66c428b62fda9753de260bfc819ee24846bc100021f103d2dcc432a9a8a60d310737470c7a4afece4fef557f72da40470ea950f8198bda0e SHA512 24a5f5306b90c763e803c34d3f20227ae0f22e6ff4192a0550e9e3050173b50f2b2e391250f1733676eca45002a061e2c753e7546db7dd21af7c1ed0857f329f
diff --git a/dev-libs/intel-neo/intel-neo-19.48.14977.ebuild b/dev-libs/intel-neo/intel-neo-19.48.14977.ebuild
new file mode 100644 (file)
index 0000000..09ff894
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+MY_PN="compute-runtime"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for OpenCL, for Gen8 (Broadwell) and beyond"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="vaapi"
+
+BDEPEND="virtual/pkgconfig"
+COMMON="dev-libs/ocl-icd
+       >=dev-util/intel-graphics-compiler-1.0.2990
+       >=media-libs/gmmlib-19.3.4
+       vaapi? (
+               x11-libs/libdrm[video_cards_intel]
+               >=x11-libs/libva-2.0.0
+       )"
+DEPEND="${COMMON}
+       media-libs/mesa"        # for Khronos OpenGL headers
+RDEPEND="${COMMON}"
+
+DOCS=(
+       README.md
+       documentation/FAQ.md
+       documentation/LIMITATIONS.md
+)
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+       local mycmakeargs=(
+               -DKHRONOS_GL_HEADERS_DIR="${EPREFIX}/usr/include"
+               -DDISABLE_LIBVA=$(usex vaapi "OFF" "ON")
+               # If enabled, tests are automatically run during the compile phase
+               # - and we cannot run them because they require permissions to access
+               # the hardware.
+               -DSKIP_UNIT_TESTS=ON
+       )
+       cmake-utils_src_configure
+}
+
+pkg_postinst() {
+       "${ROOT}"/usr/bin/eselect opencl set --use-old ocl-icd
+}