x11-drivers/xf86-video-ati: Version bump to 19.1.0
authorMatt Turner <mattst88@gentoo.org>
Tue, 15 Oct 2019 18:07:42 +0000 (11:07 -0700)
committerMatt Turner <mattst88@gentoo.org>
Tue, 15 Oct 2019 18:08:40 +0000 (11:08 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-drivers/xf86-video-ati/Manifest
x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild [new file with mode: 0644]

index 05f2cb42a7ba260b05a79ac83ef931d4b54296eb..0b5d98843b64a1ae5203f4c3de6e8ce4f3fdde67 100644 (file)
@@ -1 +1,2 @@
 DIST xf86-video-ati-19.0.1.tar.bz2 902825 BLAKE2B 8f66ee5e465c9997d356593c58e4861ad749ba1d2a7f2520e8aea871ed71d2295ac1fba75f97ca30a7dd4cfe63f775838c5a925251331e1cd1e58b9186b3ca03 SHA512 e04c5395e3a49d81b8f7a4b0e11fe8c9ebd17af056a4eab4541873796dce05b103c93fb185f3a00873010df0655cd7311e6d27e177aeb7345c4c8017bbd1eb17
+DIST xf86-video-ati-19.1.0.tar.bz2 904558 BLAKE2B 424e8b3c6fa14fa4f0bc00940bdf1008400f25ce7103b13ecefdbda9e629239c5ab011952d19c305251e9c0008650da3db0eb91055d5585e2b1c3dd108a74d86 SHA512 73a81f6c492daf2e89067fb52b3033dc0fe6841f109627ddca1aee54a45a738c8c134443753a2a2aaa2c131e1d560057ebc76351ff2304c16407df3ff568fcd6
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild
new file mode 100644 (file)
index 0000000..252dd5e
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DRI=always
+inherit linux-info xorg-3
+
+if [[ ${PV} == 9999* ]]; then
+       SRC_URI=""
+else
+       KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="https://www.x.org/wiki/ati/"
+
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.89[video_cards_radeon]
+       >=x11-libs/libpciaccess-0.8.0
+       glamor? ( x11-base/xorg-server[glamor] )
+       udev? ( virtual/libudev:= )"
+DEPEND="${RDEPEND}
+       x11-base/xorg-proto"
+
+pkg_pretend() {
+       if use kernel_linux ; then
+               if kernel_is -ge 3 9; then
+                       CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+               else
+                       CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+               fi
+       fi
+       check_extra_config
+}
+
+pkg_setup() {
+       XORG_CONFIGURE_OPTIONS=(
+               $(use_enable glamor)
+               $(use_enable udev)
+       )
+}