net-firewall/firehol: version bump
authorAlon Bar-Lev <alonbl@gentoo.org>
Sat, 18 Aug 2018 04:50:43 +0000 (07:50 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Sat, 18 Aug 2018 04:50:43 +0000 (07:50 +0300)
Closes: https://github.com/gentoo/gentoo/pull/9606
Package-Manager: Portage-2.3.40, Repoman-2.3.9

net-firewall/firehol/Manifest
net-firewall/firehol/firehol-3.1.6.ebuild [new file with mode: 0644]

index f544ddca6fef2ab9ff7303438fe293e25bc2a760..7419c1e9478c0e55d81386da5f6359efb9e7bc38 100644 (file)
@@ -1,2 +1,3 @@
 DIST firehol-3.1.3.tar.xz 1476220 BLAKE2B 19ac9db805fc4452b447a45a7ed35c781bc8595f3ede0af7de0ff5a89ab50a9f8a634e0754869774d767b50d720019a5ac466e9d1726a75a34a283473b17a94b SHA512 6c75b57650d918cfc485f6eb01d69694acd5c7b487a10a566fc26b8d5e0cd6a6a9a09bd8d3219bf4e78aa4fe47f83e5ac399107a07770b787e1ccba3078c5f3f
 DIST firehol-3.1.4.tar.xz 1481320 BLAKE2B 0fabef4a853aece966a8f273cc82947a6e63ac44ccac2494d5d6a2f0916658a78cfe0c28cc2414e797411e4795216400b1fa95193a619f7e26fe545182a5fc44 SHA512 1a17b6e810274b346f66788c4c4736421583e6a4ed76df7a1d7f46dcb99e434460998c05755c8342941413d23c02e2ca0d0bf2123cb555a6c7513d24983a13ed
+DIST firehol-3.1.6.tar.xz 1484424 BLAKE2B aea45aa424b7b43ed0576916f52a785601a21489263c1b5c6abbf3b2b97db80bf2a2420ae8176cd55e335ab93c18a8209a47f467dba80a63cf2c319b3e3e27d8 SHA512 5ffa7e59d3f10a6c7d3f5b5ef9d93f1b2138063374a10cb0c1ac4e75578d6cf7755e154b51febf546563ba003f100af13f89bca3843b66a8d22b8fc2da3fadfe
diff --git a/net-firewall/firehol/firehol-3.1.6.ebuild b/net-firewall/firehol/firehol-3.1.6.ebuild
new file mode 100644 (file)
index 0000000..b4f770d
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info
+
+DESCRIPTION="iptables firewall generator"
+HOMEPAGE="https://firehol.org/ https://github.com/firehol/firehol"
+SRC_URI="https://github.com/firehol/firehol/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc ipv6 ipset"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="net-firewall/iptables
+       sys-apps/iproute2[-minimal,ipv6?]
+       net-misc/iputils[ipv6?]
+       net-misc/iprange
+       net-analyzer/traceroute
+       virtual/modutils
+       app-arch/gzip
+       ipset? (
+               net-firewall/ipset
+       )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+       local KCONFIG_OPTS=" \
+               ~IP_NF_FILTER \
+               ~IP_NF_IPTABLES \
+               ~IP_NF_MANGLE \
+               ~IP_NF_TARGET_MASQUERADE
+               ~IP_NF_TARGET_REDIRECT \
+               ~IP_NF_TARGET_REJECT \
+               ~NETFILTER_XT_MATCH_LIMIT \
+               ~NETFILTER_XT_MATCH_OWNER \
+               ~NETFILTER_XT_MATCH_STATE \
+               ~NF_CONNTRACK \
+               ~NF_CONNTRACK_IPV4 \
+               ~NF_CONNTRACK_MARK \
+               ~NF_NAT \
+               ~NF_NAT_FTP \
+               ~NF_NAT_IRC \
+       "
+       linux-info_pkg_setup
+}
+
+src_configure() {
+       econf \
+               --disable-vnetbuild \
+               $(use_enable ipset update-ipsets) \
+               $(use_enable doc) \
+               $(use_enable ipv6)
+}
+
+src_install() {
+       default
+
+       newconfd "${FILESDIR}"/firehol.conf.d firehol
+       newinitd "${FILESDIR}"/firehol.initrd firehol
+       newconfd "${FILESDIR}"/fireqos.conf.d fireqos
+       newinitd "${FILESDIR}"/fireqos.initrd fireqos
+}