xfce-extra/xfce4-whiskermenu-plugin: Switch to cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 1 Jan 2020 17:29:43 +0000 (18:29 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 1 Jan 2020 17:30:46 +0000 (18:30 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild
xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.4.ebuild

index 530eae19a64a2678077a888270062f1b3cb07891..bb864569bdf28901c193d9a5a9b64e04c5c36dbd 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
 
 DESCRIPTION="Alternate application launcher for Xfce"
 HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
@@ -35,7 +35,7 @@ src_prepare() {
        # fix build failure w/ xfce4-panel-4.15.0
        sed -i -e 's@<libxfce4panel/xfce-panel-plugin\.h>@<libxfce4panel/libxfce4panel.h>@' \
                panel-plugin/register-plugin.c || die
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -45,7 +45,7 @@ src_configure() {
                -DENABLE_DEVELOPER_MODE=OFF
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 pkg_postinst() {
index c4bf5884ef50a70bff37b8a68cbbe404d7fc64d8..203d930b0b47fe6ef9cbda07b223a049eecef2d6 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
 
 DESCRIPTION="Alternate application launcher for Xfce"
 HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
@@ -35,7 +35,7 @@ src_prepare() {
        # fix build failure w/ xfce4-panel-4.15.0
        sed -i -e 's@<libxfce4panel/xfce-panel-plugin\.h>@<libxfce4panel/libxfce4panel.h>@' \
                panel-plugin/register-plugin.c || die
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -45,7 +45,7 @@ src_configure() {
                -DENABLE_DEVELOPER_MODE=OFF
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 pkg_postinst() {