Version bump.
authorJoshua Nichols <nichoj@gentoo.org>
Fri, 5 Jan 2007 04:24:29 +0000 (04:24 +0000)
committerJoshua Nichols <nichoj@gentoo.org>
Fri, 5 Jan 2007 04:24:29 +0000 (04:24 +0000)
Package-Manager: portage-2.1.2_rc4-r4

dev-java/jruby/ChangeLog
dev-java/jruby/files/digest-jruby-0.9.2 [new file with mode: 0644]
dev-java/jruby/files/jruby-0.9.2-haltonfailure.patch [new file with mode: 0644]
dev-java/jruby/files/jruby-0.9.2-old_jline.patch [new file with mode: 0644]
dev-java/jruby/jruby-0.9.2.ebuild [new file with mode: 0644]
dev-java/jruby/metadata.xml

index bdd28c05cfc8a83080a874394cbd2aabde596723..1ff8ff47d67da4c1213a5bed4958bb7733943c39 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-java/jruby
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/ChangeLog,v 1.11 2006/11/10 21:05:02 betelgeuse Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/ChangeLog,v 1.12 2007/01/05 04:24:29 nichoj Exp $
+
+*jruby-0.9.2 (05 Jan 2007)
+
+  05 Jan 2007; Joshua Nichols <nichoj@gentoo.org>
+  +files/jruby-0.9.2-haltonfailure.patch,
+  +files/jruby-0.9.2-old_jline.patch, metadata.xml, +jruby-0.9.2.ebuild:
+  Version bump.
 
   10 Nov 2006; Petteri Räty <betelgeuse@gentoo.org> jruby-0.9.1.ebuild:
   Stylistic fixes.
diff --git a/dev-java/jruby/files/digest-jruby-0.9.2 b/dev-java/jruby/files/digest-jruby-0.9.2
new file mode 100644 (file)
index 0000000..eb56eda
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6dcd06bd5bb6f6a785e23210aabf3fe4 jruby-src-0.9.2.tar.gz 4696196
+RMD160 cadcd4b1b3fab3695f60c854257a5e45d0fa892f jruby-src-0.9.2.tar.gz 4696196
+SHA256 306276034c7d9dd37618ff31aa3a600bd38371edb8d2e0fb58dfa54af879e132 jruby-src-0.9.2.tar.gz 4696196
diff --git a/dev-java/jruby/files/jruby-0.9.2-haltonfailure.patch b/dev-java/jruby/files/jruby-0.9.2-haltonfailure.patch
new file mode 100644 (file)
index 0000000..61451f1
--- /dev/null
@@ -0,0 +1,13 @@
+Only in jruby-0.9.2-patched/: .build.xml.swp
+diff -ru jruby-0.9.2/build.xml jruby-0.9.2-patched/build.xml
+--- jruby-0.9.2/build.xml      2006-12-10 13:08:05.000000000 -0500
++++ jruby-0.9.2-patched/build.xml      2007-01-04 21:53:00.000000000 -0500
+@@ -314,7 +314,7 @@
+   <target name="test" depends="copy-test-files,instrument,run-junit,coverage-report"/>
+   <target name="run-junit" description="runs junit tests">
+     <taskdef name="junit" classname="org.apache.tools.ant.taskdefs.optional.junit.JUnitTask" classpath="${lib.dir}/junit.jar"/>
+-    <junit fork="yes" haltonfailure="false" dir="${basedir}" maxmemory="256M">
++    <junit fork="yes" haltonfailure="true" dir="${basedir}" maxmemory="256M">
+       <classpath>
+               <pathelement location="${jruby.instrumented.classes.dir}" />
+         <path refid="build.classpath"/>
diff --git a/dev-java/jruby/files/jruby-0.9.2-old_jline.patch b/dev-java/jruby/files/jruby-0.9.2-old_jline.patch
new file mode 100644 (file)
index 0000000..1c6ce2a
--- /dev/null
@@ -0,0 +1,17 @@
+diff -ru jruby-0.9.2/src/org/jruby/ext/Readline.java jruby-0.9.2-patched/src/org/jruby/ext/Readline.java
+--- jruby-0.9.2/src/org/jruby/ext/Readline.java        2006-12-10 13:07:09.000000000 -0500
++++ jruby-0.9.2-patched/src/org/jruby/ext/Readline.java        2007-01-04 20:11:04.000000000 -0500
+@@ -85,8 +85,13 @@
+     protected static void initReadline() throws IOException {\r
+         readline = new ConsoleReader();\r
+         readline.setUseHistory(false);\r
++\r
++              // disabled until jline-0.9.91 is released. see\r
++              // http://jira.codehaus.org/browse/JRUBY-383\r
++              /*\r
+         readline.setUsePagination(true);\r
+         ((CandidateListCompletionHandler) readline.getCompletionHandler()).setAlwaysIncludeNewline(false);\r
++              */\r
+         if (currentCompletor == null) {\r
+             currentCompletor = new RubyFileNameCompletor();\r
+             readline.addCompletor(currentCompletor);\r
diff --git a/dev-java/jruby/jruby-0.9.2.ebuild b/dev-java/jruby/jruby-0.9.2.ebuild
new file mode 100644 (file)
index 0000000..dafaf24
--- /dev/null
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/jruby-0.9.2.ebuild,v 1.1 2007/01/05 04:24:29 nichoj Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Java based ruby interpreter implementation"
+HOMEPAGE="http://jruby.codehaus.org/"
+SRC_URI="http://dist.codehaus.org/${PN}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc source test"
+
+COMMON_DEPEND=">=dev-java/jvyaml-0.2
+       dev-java/jline
+       =dev-java/asm-2.2*
+       =dev-java/bsf-2.3*"
+RDEPEND=">=virtual/jre-1.4
+       ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+       !test? ( dev-java/ant-core )
+       test? (
+               dev-java/junit
+               dev-java/ant
+       )
+       source? ( app-arch/zip )
+       ${COMMON_DEPEND}"
+
+EANT_DOC_TARGET="create-apidocs"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       # 0.9.2 was using a version of jline which hasn't been released, which has
+       # a few new methods. disabling calls to those methods, but shouldn't affect
+       # usablility. see
+       #       http://jira.codehaus.org/browse/JRUBY-383
+       epatch ${FILESDIR}/${P}-old_jline.patch
+       # fix javadoc, make tests halt on failure
+       epatch ${FILESDIR}/${P}-haltonfailure.patch
+
+       cd lib
+       # created by jruby dev, but no source available, so use bundled
+       mv plaincharset.jar "${T}"
+       rm -rf *.jar
+       mv "${T}/plaincharset.jar" .
+
+       java-pkg_jar-from --build-only ant-core ant.jar
+       java-pkg_jar-from asm-2.2 asm.jar
+       java-pkg_jar-from bsf-2.3
+       java-pkg_jar-from jvyaml
+       java-pkg_jar-from jline
+       use test && java-pkg_jar-from --build-only junit
+}
+
+src_install() {
+       java-pkg_dojar "lib/${PN}.jar" "lib/plaincharset.jar"
+
+       dodoc README COPYING COPYING.CPL COPYING.GPL COPYING.LGPL
+
+       if use doc; then
+               java-pkg_dojavadoc docs/api
+               docinto docs
+               dodoc docs/*
+       fi
+       use source && java-pkg_dosrc src/org
+       java-pkg_dolauncher ${PN} \
+               --main 'org.jruby.Main' \
+               --java_args '-Djruby.base=/usr/share/jruby -Djruby.home=/usr/share/jruby -Djruby.lib=/usr/share/jruby/lib -Djruby.script=jruby -Djruby.shell=/bin/sh'
+       newbin ${S}/bin/gem jgem
+       newbin ${S}/bin/gem_server jgem_server
+       newbin ${S}/bin/gemlock jgem_lock
+       newbin ${S}/bin/gemri jgemri
+       newbin ${S}/bin/gemwhich jgemwhich
+       newbin ${S}/bin/update_rubygems jupdate_rubygems
+#      newbin ${S}/bin/generate_yaml_index.rb jgenerate_yaml_index.rb
+       newbin ${S}/bin/index_gem_repository.rb jindex_gem_repository.rb
+       dobin ${S}/bin/jirb
+
+       dodir "/usr/share/${PN}/lib"
+       insinto "/usr/share/${PN}/lib"
+       doins -r "${S}/lib/ruby"
+}
+
+src_test() {
+       eant test
+}
index 7303cef9696423b08062072773a9ea8ab5a6bd4f..b0864a093b9359e9801925ed6124e66607f13ef3 100644 (file)
@@ -2,4 +2,8 @@
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
        <herd>java</herd>
+       <maintainer>
+               <email>nichoj@gentoo.org</email>
+               <name>Joshua Nichols</name>
+       </maintainer>
 </pkgmetadata>